Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I see no cpufreq performance module:

$ ll /lib/modules/2.6.32-358.2.1.el6.x86_64/kernel/drivers/cpufreq/
total 88<br/>
-rwxr--r--. 1 root root 20576 Mar 12 18:26 cpufreq_conservative.ko
-rwxr--r--. 1 root root 27096 Mar 12 18:26 cpufreq_ondemand.ko
-rwxr--r--. 1 root root  5336 Mar 12 18:26 cpufreq_powersave.ko
-rwxr--r--. 1 root root 14120 Mar 12 18:26 cpufreq_stats.ko
-rwxr--r--. 1 root root 10920 Mar 12 18:26 freq_table.ko

Then, further search online shows that it should be part of the kernel instead of a loadable module (for CentOS 5)?
http://lists.centos.org/pipermail/centos/2010-July/097217.html

I am on CentOS 6 now.

Does it mean that I have to recompile the kernel from source in order to enable cpufreq performance?

Update #1: For some reasons, I don't see the folder (David mentioned) on CentOS 6:

$ ll /sys/devices/system/cpu/cpu0/
total 0<br/>
drwxr-xr-x. 6 root root    0 Mar 14 23:41 cache
drwxr-xr-x. 6 root root    0 Mar 15 01:29 cpuidle
-r--------. 1 root root 4096 Mar 14 23:41 crash_notes
drwxr-xr-x. 2 root root    0 Mar 15 01:29 microcode
lrwxrwxrwx. 1 root root    0 Mar 15 01:29 node0 -> ../../node/node0
drwxr-xr-x. 2 root root    0 Mar 15 01:29 thermal_throttle
drwxr-xr-x. 2 root root    0 Mar 14 23:41 topology

Update #2:

$ sudo cpufreq-set -c 0 -g performance
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?
share|improve this question
    
add comment

2 Answers

Even if you see it from command below:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors 

it doesn't mean it's going to work.

It requires that the kernel is compiled with the cpufreq_performance if you're using the performance governor.

The previous comment is not correct about if it lists you can use it, wrong.

You can verify by

watch grep \"cpu MHz\" /proc/cpuinfo

using sudo of course. If the FREQ changes then you know it's working.

Required - cpufreq_performance.ko module <-- You can check to make sure it exists by running.

First make sure acpi-cpufreq.ko is available.

ls /lib/modules/{kernel version}/kernel/arch/x86/kernel/cpu/cpufreq/

ls /lib/modules/{kernel version}/kernel/drivers/cpufreq/

If the cpufreq_performance.ko module doesn't exist that means you'll need to compile it.

share|improve this answer
add comment

From what I can see (on my Fedora Box), the performance governor is compiled in to the system, so you can just use it.

I am able to check the available governors by using the command

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

(And it shows the performance governor even though this is not compiled as a module).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.