Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want conky visible at all times and all windows to respect the boundaries of conky. They should not overlap conky. Right now when i open a new application it overlaps conky and i have to manually drag it to the left. I want that apps never appear over conky. Can it be done?

share|improve this question
1  
You should include in your question which window manager you are using. –  mpy Mar 14 '13 at 11:39
    
Unity. Ubuntu 12.04 –  koogee Mar 14 '13 at 14:49

2 Answers 2

Add these lines to your ~/.conkyrc :

own_window yes
own_window_type panel
own_window_hints above

According to conky's documentation (emphasis mine):

if own_window is yes, you may specify type normal, desktop, dock, panel or override (default: normal). Desktop windows are special windows that have no window decorations; are always visible on your desktop; do not appear in your pager or taskbar; and are sticky across all workspaces. Panel windows reserve space along a desktop edge, just like panels and taskbars, preventing maximized windows from overlapping them. The edge is chosen based on the alignment option. Override windows are not under the control of the window manager. Hints are ignored. This type of window can be useful for certain situations.

share|improve this answer
    
The only thing panel mode does is draw conky over the window open on the same area. That results in windows appearing weirdly cut off on the right side. Is there a way that apps don't open in that area at all or resize if they reach the boundary. –  koogee Mar 14 '13 at 14:58
    
@koogee In panel mode, maximized windows will not overlap conky. Another option would be to use own_window_type normal and set it to "always on top". Very ugly though. I'm pretty sure that's the best you can do though. –  terdon Mar 14 '13 at 16:06
    
Is there any way to tell the window manager to leave that area? like if i have 1920x1080 res, the WM should only consider 1620x1080 as available screen space leaving conky on the right untouched? –  koogee Mar 16 '13 at 4:56
    
Thanks @terdon. I have own_window_type normal still in my conkyrc, changing the hints to include "above" was the trick that did it for me! –  Ash Dec 23 '13 at 4:25

I have conky setup this way, but it runs down the right of the screen. I use fbpanel to affect the no overlap.

~/.conkyrc:

own_window yes
own_window_type dock
own_window_transparent yes

maximum_width 160
gap_x 1755
gap_y 1

~/.config/fbpanel/default:

Global {
    edge = right
    allign = center
    margin = 0
    widthtype = pixel
    width = 0
    height = 172
    transparent = true
    tintcolor = #000000
    alpha = 0
    setdocktype = true
    setpartialstrut = true
    autohide = false
    heightWhenHidden = 2
    roundcorners = true
    roundcornersradius = 7
    layer = below
    MaxElemHeight = 32
    setlayer = true
}
share|improve this answer
    
Couple of questions: 1. Will this work with Unity? 2. Does this cause the windows to resize even when not maximized respecting the borders of conky? 3. If yes to both Qs, Can you point to a guide/tutorial to set this up in Ubuntu 12.04? Thanks –  koogee Sep 29 '13 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.