Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a redhat linux server running jenkins. I setup jenkins as per the instructions mentioned here https://wiki.jenkins-ci.org/display/JENKINS/Installing+Jenkins+on+Red+Hat+distributions The problem is that I need to switch to the jenkins user in order to solve an ssh connection issue, but I cannot.

I try

su - jenkins

however after I enter that, the terminal remains[root@redhat ~]# and a whoami reveals that I am still root I have looked at the files /etc/passwd etc/shadow and see that jenkins is a user, but I don't have enough experience to tell what I have done wrong in setting up this jenkins user.

any ideas would be helpful, or places to look for clues?

share|improve this question

migrated from stackoverflow.com Mar 14 '13 at 19:45

This question came from our site for professional and enthusiast programmers.

up vote 20 down vote accepted

is jenkins a service account with no shell configured in /etc/password If that's it try sudo su -s /bin/bash jenkins

share|improve this answer
3  
That's the way! Now for anyone that has similar problems /var/lib/jenkins acts as the home dir for jenkins user and will have .ssh – OrwellHindenberg Mar 14 '13 at 16:06
2  
You could also run sudo -u jenkins bash – B2F Mar 6 '15 at 14:29

The other option would be to change the shell for jenkins.

Run the below command:

chsh -s /bin/bash jenkins

Now you will be able to switch as jenkins user by just passing su jenkins

share|improve this answer
    
Do not do this. the account lacks a shell for good reason - service accounts shouldn't be able to log in interactively. This is a security risk with no real benefit. – thekbb May 10 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .