Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old solaris system with terabytes of data on it. Recently we got a new server and I went along with the recommendation of a windows server "because it was easy to manage". Someone copied the data from the solaris box onto the new server. All the data is there but somehow we seem to have lost all the ownership and permissions. Now even administrator accounts can't actually access the data on the windows share. I've tried everything I can think of to copy the permissions and ownership across. I've tried cacls to add permissions for the Administrator and Domain Admins but I just get error messages.

cacls files /t /e /c /g "administrator":f
ACCESS_DENIED: D:\Public\files\something

On a linux/unix fileserver I can see the permissions of all the files in a directory with an "ls". On this system I need 10 minutes and half a dozen dialog boxes just to see the permissions.

I've tried to copy the permissions and ownerships from the source directory mounted using NFS and samba with rsync and robocopy run by the Administrator. Nothing useful happened. Mounting the source directory with NFS I couldn't see owners names, just UIDs. Mounting them as CIFS shares I could see the owners.

robocopy j:\olddrive\files d:\newdrive\files /e /purge /secfix /copy:atsou /dcopy:t /timfix

outputs lots of stuff but doesn't AFAICT change permissions and definitely doesn't change ownership.

Now I'm sure the data as it grew over many years probably has stuffed permissions, stuffed unix permissions, but it was at least useable. Now with a much more complex set of permissions it's not even accessible. AFAIC this is a giant step backwards.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.