Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Problem

I need to compile and install an Apache module on AIX 6.1. This is the module

A. The Apache module is available only as source. I manageg to compile the source and the .so module was created, but when I start httpd server, I get this error :

Could not load module /../httpd.2.2.x/modules/mod_authnz_crowd.so.\n\tDependent module ../httpd.2.2.x/lib/libapr-1.a(libapr-1.so.0.4.6) could not be loaded.\n\tMember libapr-1.so.0.4.6 is not found in archive

My conclusion : its searching for a httpd.2.2.x/lib/libapr-1.a which contains libapr-1.so.0.4.6


B. So I searched for this library libapr-1.a in other places on my system; its present and contains the .so also

user@myserver : cd /usr/lib

user@myserver : ls -la libapr-1.a

libapr-1.a -> ../../opt/freeware/lib/libapr-1.a

user@myserver : ar -v -t libapr-1.a

rwxr-xr-x 0/0 922171 Jul 24 22:05 2012 libapr-1.so.0.4.6


Question

Is it a linking, LIB, LIBPATH etc. problem ? How do I fix it.


More Info

  • If I create a link httpd.2.2.x/lib/libapr-1.a -> ../../opt/freeware/lib/libapr-1.a , it gives a core dump.

  • Since this project depends on a lot of other libs, setting LIB=opt/freeware/lib makes it fail for other dependencies

  • During make install is when it tries to restart apache and I get the above error. To test, I removed the references to this module from the httpd.conf and the server was running again.

  • I tried to compile a different version of apache from source earlier which was not completely successful. I have also installed an apr rpm which was required as a dependency somewhere. So is this because there is a mix up of versions of apr, apr-util and apache ?

share|improve this question

migrated from stackoverflow.com Mar 15 '13 at 8:15

This question came from our site for professional and enthusiast programmers.

    
Your question is tagged with "unix" but you installed an apr RPM file... which is your OS? –  jaume Mar 18 '13 at 12:13
    
@jaume sorry.. shd have mentioned. Update the question' –  Pulak Agrawal Mar 18 '13 at 14:53
    
The linking should have worked, but a core dump suggests you are facing a tricky problem. I had a look at the Atlassian documentation in confluence.atlassian.com/display/CROWD/… and other people have struggled to get the connector working in any Linux/Unix distro other than RedHat. You say you don't have root privileges and you state in the linked SO question: I am not *nix expert, rather at basic user level. And any installations are actually done by the admins. Can't you ask the admins for advise/help? –  jaume Mar 19 '13 at 12:49
    
@jaume thanks.. unfortunately the admins are no able to help anymore.. hence I landed here :). Open to experiment.. like copying all required libs into a new directory.. and pointing to that (don't know how to do the pointing part).. or something else.. I don't know –  Pulak Agrawal Mar 20 '13 at 1:47
    
I was going to try to rephrase your title to a question, but once I got into the body of it, I have no idea what you're asking, so I don't think I'm fit to paraphrase it for you. –  killermist Mar 21 '13 at 20:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.