Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 7 machine was powered down without logging out first. Now, when booting the PC; Windows 7 does not completely start. Instead, it boots to an completely black screen with a mouse cursor that can be moved around but not used to interact with anything. In other words; there are no icons or tool bars.

Ctrl+Alt+Del does not bring up the Task Manager. Booting to Safe Mode renders the same result.

share|improve this question
    
If you suspect hardware, then you need to start testing your hardware. :) Start by testing your hard drive(s) and RAM; there are several questions on here to help you figure out how to do each of those. –  Ƭᴇcʜιᴇ007 Sep 21 '11 at 20:40
    
Right click on the black screen and select "screen resolution" if it is available, select a low resolution. –  Moab Sep 22 '11 at 3:41

7 Answers 7

This is known as a KSOD (blacK Screen Of Dead), it's not to be confused with the more popular term BSOD (Blue Screen Of Death); a KSOD happens after the login screen where as you describe the screen would turn blank/black with only a mouse cursor to interact with exactly nothing.

At this point, the OS is supposed to load the shell. If, however, the shell that needs to be loaded has been set to something different or the shell itself has been corrupted/damaged then it might not be able to load as you could see here. PrevX has written an easy fix which you can grab by clicking on this link to fix the KSOD issue, this simply does the following:

  • Correct the ACL permissions of the following key to the default permissions:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  • Recreate a REG_SZ string called Shell and set it to explorer.exe.

You need to put back explorer.exe by simply executing sfc /scannow if it is broke.

In case you can't get to CTRL+ALT+DEL or Safe Mode, you'll need to start from the installation medium:

  1. Insert the installation medium, get to the recovery mode but don't let it recover things.

  2. Start up the command line.

  3. In case you want to manually adjust registry changes, start regedit and load the hives in:

    C:\Windows\System32\config

  4. In case you want to automatically fix this issue, run the following two commands:

    • sfc /scannow to fix Operating System files, which should put explorer.exe back.

    • fixshell.exe, the tool you downloaded from PrevX, which fixes the registry.

Be sure that you have tried to upgrade your graphics drivers, because you might not have a mouse cursor at all and be reading this. Other people report to remove media like DVDs or Bluray disks, which might interfere with your boot...

share|improve this answer
    
is there any way to do the equivalent with like an ubuntu livecd I wonder... –  rogerdpack Aug 22 '13 at 20:22
2  
Fyi the link attached is not working. –  Rene Brakus Jan 23 at 7:55

I had the same issue, but it appeared to be the video driver... windows took the HDMI port as primary screen while there wasn't a screen connected to the HDMI port... so I only had a blank screen and a mouse pointer on my screen connected to the vga port... I was able to fix that using the right mouse button and "personalize" and then disabled the primary screen and made the other one (the VGA port) primary.


OTOH I've also had a similar issue with Vista AFTER I changed the structure of my partitions using Acronis Disk Manager, then I wasn't able to get a context-menu out of right mouse button. Just the mouse pointer and a blank screen... I did get the logon screen when pressing ctrl-alt-del though, but couldn't do anything but shut down.
Actually I still have this problem now (but I dual boot to Windows 7 RC 1 all the time, so it is not actually a problem any more, but I would like to know a workaround if you find one!)

share|improve this answer

I just spent a day with this problem. My machine ran too well in safe mode to have a hardware problem or even a virus.

Removing and reinstalling the nVidia drivers would fix the problem for one boot but the problem would return on the next. I'd bet a black screen with a functional cursor but noting else. Sometimes letting the computer sit for hours would fix the problem but even that would only work some of the time.

After working on this for about a day and including about 50 reboots, it turns out that simply removing the blu-ray DVD I'd forgotten in the D: dive fixed the problem. Apparently the computer looked at the D: drive and put the display adapter in a mode that was incompatible with my monitors.

Just a goofy disk in one of the drives....

share|improve this answer

i had a computer with the same problem.the duser.dll file was corrupt. but there are more files involved in the user environment loading process. get yourself a DOK and ubuntu cd and try replacing the boot files of windows. another possibility is to connect the HD to another computer and use offline sfc. sfc /scannow /windir=x:\windows /offbootdir=x:

share|improve this answer
2  
Just use the installation medium, that makes sfc /scannow a lot easier. –  Tom Wijsman Aug 11 '11 at 11:38

I had this problem today. I'm not sure what changed about my computer, but it couldn't get past the blank screen (with cursor) on boot.

The problem was gone after doing these steps (I'm not sure which are the solution):

  1. I let the boot process run a disk check (which it prompted automatically and I didn't decline).
  2. I booted either into VGA Mode or Safe Mode
  3. I ran netplwiz and checked the box for "Users must enter a user name and password..."
  4. I ran msconfig and deselected these apps (on the Startup tab) from starting on login:
    • Bitcasa
    • Plex
    • Google Update
    • Adobe Updater Startup Utility
    • Adobe Reader and Acrobat Manager
    • LiveDrive
    • PlayOn System Tray Monitor
    • SASSystemPrep
    • Spotify
    • OpenVPN Client
  5. Unplugged my second monitor (so that only 1 was plugged in)
  6. Unplugged USB sticks and other unnecessary USB components
  7. Ensured the CD/DVD trays were empty
  8. Reboot
share|improve this answer
    
I guess you had a blinking cursor, not the mouse pointer of the OP? –  rogerdpack Aug 20 '13 at 16:18
    
I had a mouse pointer that occasionally would turn into a spinning circle (the modern version of an hourglass). –  Ryan Aug 20 '13 at 23:11
    
I'm so glad that I wrote these notes here! This problem just happened to me again tonight. To solve it, I did Step 1, Step 2 (safe mode), Step 3 was already done, Step 4 was already done (and I also unchecked vpngui.exe), Step 5 (which I think is the key!!), and Steps 6 and 7 were already done. Then it booted into Windows 7 fine. Then I reconnected my Asus VH242H monitor, which then worked immediately. I wonder if there flakiness with my Asus VH242H. –  Ryan Oct 9 '13 at 2:50

It sounds like you have the infamous stop error. Since you can't run your PC in safe mode, I would try to do a clean install of Windows 7. Hopefully you have your data backed up, because it will clear everything on your hard drive. In case you don't want to resort to that, however, there's other options that you could try out listed here:

http://windows.microsoft.com/en-us/windows7/Resolving-stop-blue-screen-errors-in-Windows-7

share|improve this answer
    
No, he does not experience a BSOD. –  Tom Wijsman Aug 11 '11 at 11:39

Use F8 at the start of booting to get the Windows Advanced Boot Options screen, select "enable vga mode", see if it will load graphics now.

. enter image description here

share|improve this answer

protected by Diago Jan 6 '11 at 16:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?