Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I typically use the left Alt key for apps like Photoshop, Maya and Blender (in Photoshop afaik, this key cannot be changed).

Linux Mint 14 with Cinnamon defaults to using the left Alt as the movement key (Alt + leftClick-drag to move windows, which is great, and I'd like to retain this functionality by swapping it over to the Super_L (/Win key).

I used dconf-editor to check mouse-button-modifier under org.gnome.desktop.wm.preferences but this is set to <Super> already (I have tried setting it to <Super_L> to no effect.

Under Cinnamon Settings - Keyboard - Keyboard Shortcuts - Cinnamon "Menu Button" is set to <Super_L> such that when I press the left super key, it opens the Cinnamon menu.

I got it working nicely in Ubuntu 11.10 a few years back but can't seem to manage it now. In summary, I'd like:

  • Alt (left) - unassigned, so that applications (Photoshop, Maya, Blender) can use it in combination with mouse clicks/movements

  • Super (left) - to open (and close if possible) the Cinnamon menu, as it does now, but also to act as the mouse-modifier when I click and drag on Windows

I can't see where Alt is assigned at all, so don't know where to turn it off - in Ubuntu, changing the mouse modifier using gconf-editor to the Super key was enough to achieve the above points.

Are Cinnamon restarts/logging in and out/restarting machine necessary steps?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The lines changed in /usr/lib/cinnamon-settings/cinnamon-settings.py by this patch let me change the Alt+Click window movement to Super+Click.

In Linux Mint 14, the new settings appears under Menu >> Preferences >> Cinnamon Settings >> Windows and is called "Modifier to use for modified window click actions".

share|improve this answer
    
works in 15 too, thanks! –  ataulm Jul 19 '13 at 1:37
    
This is how I was able to use ALT as my crouch button in Left 4 Dead on Steam. However, setting the key to None didn't work, it had to be Super. –  Thav Aug 2 '13 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.