Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update: This is NOT for fixing corrupt icons - this is for changing icons, corrupt or not.

Original queston

This is NOT for the library icon nor for the Metro icons. This is for Windows 8 Explorer icons.

I'm able to change the default program from control panel or right click file in Explorer => properties. But I can't see a way to change the icon itself. I'm putting a screenshot of what I'm presented - the same holds true for PDF files or any other files.

enter image description here

Edit: Even when I try to change the icons of shortcuts, I'm unable to do so. Weird!

enter image description here

Any ideas?

share|improve this question
For starters, you can't change special shortcut icons, like those in Microsoft Office. Secondly, you'll have to play around with the extensions in the Registry, which is not supported by Microsoft. – user3463 Mar 16 '13 at 2:19
@RandolphWest: What is your solution? – DeepSpace101 Mar 16 '13 at 2:24
up vote 2 down vote accepted

Create a new shortcut from the original MSOffice .exe file, and then you can change it's icon. This works in Windows 7 or Windows 8.

. To create one, search the

program files(x86)\office 14(or 15)\


program files\Office 14(or 15)\

for the exe you want, and then right-click drag the .exe somewhere like desktop where you can create a shortcut. You can then change the icon.


enter image description here


enter image description here


share|improve this answer

Go to Microsoft OfficeMicrosoft Office ToolsMicrosoft Office Picture ManagerHelpDetect and Repair.

Check Restore my shortcuts while repairing.

This should restore all the Microsoft Office shortcuts and icons.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .