Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I put the USB into my PC it says: "You need to format the disk in drive G: before you can use it. Do you want to format it?". I press cancel and when I open the drive it says: "Please insert a disk into Removable Disk (G:).". Can I somehow get some if not all the data from the USB? Thanks in advance~ Edit: By the way, it's a Kingston 2gb USB.

share|improve this question

5 Answers 5

You can format it and use PhotoRec from TestDisk to recover the data. Just remember not to write anything on the drive between formatting it and running photorec. That might overwrite old data, making it impossible to recover.

share|improve this answer

Usually when I get that message I interpreted it as 'Please put the usb back into the last computer you used.' This mostly worked.

This was probably because the computer still had some files locked somehow when removing the usb. That is why you have to safely remove your usb device from the computer and not just pull it out, because this can damage your usb device.

my answer: Put it back into the computer (port) where you lastly used it. You could also try to put it in a computer with a different OS.

share|improve this answer

You could always give TestDisk example a go. I've used it for this purpose many times, works great too. From the wiki "primarily designed to help recover lost partitions and/or make non-booting disks bootable again" exactly what your looking for I think.

share|improve this answer

The best way to recover the data is to try a different PC/OS. I have several Kingston USB sticks and some of them are not readable (became) after I install Sp1 on Win 7 however I can read them just fine on Windows 8 PCs. If you have the options, try other computers, save your data and than re-format.

share|improve this answer

Some of the answers here are rather extreme to perform at first. Formatting then using PhotoRec is a good answer but one that I would only use if all other avenues have failed.

The reason your device wants to be formatted is that the header file of the partition has been corrupted or lost and therefore your PC thinks there is no data on it. Use MiniTool Partition Recovery to recover the pration, in most cases this is successful and will allow you to access and see the files on your device.

However, the likelihood is that your files have also been corrupted and therefore I would run a chkdsk /f /r on your USB drive. After that I would use PhotoRec, Recuva, PC Inspector and a number of other free data recovery tools to attempt to find and restore your lost files, personally PhotoRec has worked for me in the past on a really corrupted drive.

As I said, failing that, I would then format the drive and run the Data Recovery Software and see what happens.

If your data is still unreachable you wish to call a specialist

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.