Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For my work in a library I administer a couple of pcs, which can be used by visitors to browse the web. I keep seeing a very strange issue, that leaves me completely stomped.

When a user goes on Facebook the computer freezes for a couple of seconds, then the browser closes, an error message pops up, saying "InitiateSystemShutdown failed.". The message closes at once and the computer reboots. This doesn't always happen, half the time Facebook works fine.

The environment is as follows:

  • All PCs run Windows 7 (from the same disk image).
  • Windows, Flash and Java are fully patched.
  • The problem occurs with all recent versions of IE, Firefox, Opera or Chrome. (Although it feels as if it happens most with Chrome.)
  • The PCs are protected by Norton Antivirus and when they reboot, they are completely reset by Faronics Deep Freeze.
  • The PCs access the internet through an Ubuntu gateway server somewhere in the town hall. It applies a content filter and scans for viruses.

I am completely lost. Can anyone give me a pointer on where the problem might be? Or what I could do to narrow down the problem?

share|improve this question
1  
this is one comp? or all of them? Memory amount? –  Logman Mar 15 '13 at 21:44
1  
This is a problem? I would like to know how to cause that! j/k –  Kazark Mar 15 '13 at 21:59
    
Logman, yes it happens on all PCs and they have 4GB of RAM. (Not sure 100% on that - I'll check tomorrow morning.) –  Béné Mar 15 '13 at 22:17
    
This sounds suspiciously like a virus. I would run an anti-virus program from another source. –  Xavierjazz Mar 15 '13 at 23:09
1  
"InitiateSystemShutdown failed." is an API call to shutdown computer. Did you check the event logs to see what app is calling it? Faronics? System? Like Xavier mentioned, could be a virus and it got on your image –  Logman Mar 15 '13 at 23:13
show 1 more comment

1 Answer

up vote 1 down vote accepted

Turned my comment into answer......

"InitiateSystemShutdown failed." is an API call to shutdown computer. Did you check the event logs to see what app is calling it? Faronics? System? Like Xavier mentioned, could be a virus and it got on your image.

Why is NetLoan/Facebook locking up the browsers/computers? IS it activeX? (not with the gecko & webkit browsers). Adobe Flash? Who knows...

Create a new reference image from scratch and redeploy

share|improve this answer
    
Thanks again! NetLoan is going to publish an update to their software that should fix the rebooting part of the problem. In the meantime I'm trying to investigate the freeze using XPerf Tools. –  Béné Mar 19 '13 at 17:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.