Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Anytime I pull up a page in Firefox that uses fonts served by the site or by Google's CDN (e.g. themes.googleusercontent.com), the @font-face fonts are not downloaded/rendered by my browser. (I can, however, see webfonts served by a data: URI.)

For example, the main Google Web Fonts page looks like a bunch of Times New Roman to me. (But the Khan Academy icons referenced in this SU question show up fine for me.)

Google Web Fonts site with Times New Roman

Blogger sites that use the default Google themes all look like they meant to include Comic Sans (shudder).

Blogger site with Comic Sans instead of intended font

And sites like NetVibes that use webfonts for icons end up looking rather ridiculous.

Netvibes with no icon fonts

All of the above look fine in Google Chrome, and I know that these fonts can't be broken for everyone using Firefox, or else they never would have been launched as-is. So I put it to you -- what exactly is messed up with my Firefox install?

Technical details: I'm running FF19 (current as of time of writing) on a 64-bit install of Windows 8... but I had this same problem on my old computer, which was a 32-bit Win7. The problem has existed for several months, so it's been around since at least FF17. I do have AdBlock Plus installed with the EasyList filter, but the issue persisted when I disabled ABP and restarted, as well as when I tried a fresh Firefox profile.

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

It probably has to do with cross-site domain permissions. Firefox is a bit more stringent on those type of things.

http://www.red-team-design.com/firefox-doesnt-allow-cross-domain-fonts-by-default

You aren't the problem. This problem must be addressed by the web site operator. A possible work around is to download the fonts and install them locally, and possibly (depending on the CSS) the font's may render.

Also - if you are going through a proxy (perhaps transparent) then headers are getting modified, and that is limiting your ability to pull the fonts down.

share|improve this answer
    
I don't have any problem with the Google Web Fonts page using FF 19.0.2 on Windows 7, 64-bit. That suggests the problem isn't the cross-site permissions, or at least not that problem by itself. –  Wayne Johnston Mar 16 '13 at 16:31
3  
The issue is the second half of EdH's answer: the proxy. I have Acrylic DNS installed to create wildcards in my local hosts file. The second that I changed my network configuration to skip the DNS proxy, the webfonts loaded as expected. I'd seen cross-site domain problems on other kinds of resources, but never expected that the DNS proxy was the problem. Thanks, EdH! –  Curtis Gibby Mar 16 '13 at 23:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.