Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying out Ubuntu, installation went fine - upgraded to the proprietary nVidia drivers but on restart I get a login prompt and the screen is flashing really fast almost as if Xserver is trying to start and failing, I can type when the screen isn't in a "flash" as it were and it's so fast and random it's hard to even type a login name without it missing some characters - this makes typing a password (i.e. not being able to see which characters made it or not) very hard.

I can log back into the live cd and alter my settings - but I can't even find out how to stop X stop starting on boot; Looks like they've moved everything around :-p

I'd like to:

  • Stop X from crashing and going insane (if it is actually Xserver)
  • Know how to stop X from starting on bootup, Looks like interactive boot is also off by default now

Update: A temporary work around seems to be enabling ssh and just connecting to the box over the network - ssh seems to work fine :-p

Cheers, Chris

share|improve this question
I've tried adding in the "DontZap" option and this may have worked; It takes so long to reboot into the live cd I've not "tested" it yet but I had a boot where the screen was flickering and then all of a sudden it started the login screen - so maybe it did change somthing. – Christopher Lightfoot Oct 17 '09 at 20:26
Tried enabling Xinerama and got stuck in the same loop, so it doesn't seem to make a difference. – Christopher Lightfoot Oct 17 '09 at 21:42

If you can get logged in, you can type "sudo killall gdm", which would kill the default Ubuntu Display Manager. If not, boot using the Ubuntu CD and find the file /usr/sbin/gdm and rename it to "gdm.not" or something, so you can boot to a tty and remove the NVidia driver that (you believe) is causing the problem using aptitude. Rename gdm.not back to gdm and reboot.

share|improve this answer
Removing /etc/X11/xorg.conf allows a successfull boot - X now seems to be able to start without any settings and use some basic standard config - didn't find correct drivers or resolution but it was better than nothing :-p – Christopher Lightfoot Oct 17 '09 at 20:25

To properly fix the infinite respawn, start in recovery mode, and edit /etc/init/gdm.conf. Remove or uncomment the "respawn" line.

Now you can restart the machine, and gdm won't start at all. You can log in to a terminal, diagnose the original problem (probably a driver issue), and once you can get X to start again, you can uncomment the respawn line and restart your system.

It's a known bug in launchpad: #431166

share|improve this answer
makes me laugh how simple this is probably to fix and how insane it drives poeple (and eventually puts them off from using linux) and nobody seems to care leaving it with low priority. Leaving your machine unusable without restarting and editing config files is the realm of windows, not linux. What happened to grace? :-D. 8.10 Is still my best friend until the 9.X branch gets its act together - also still waiting for multi monitor support!! :-D – Christopher Lightfoot Nov 20 '09 at 12:28
9.x lacks muli monitor support? News to me. I have three machines running 9.04 or 10 with it. Sounds like a new question to me. – qedi Nov 20 '09 at 13:59

If you're on the console, you can try to get to a text-based virtual terminal (from the broken GUI login) by hitting Ctrl-Alt-F1 (you can also use F2-F6; switch back to the X virtual terminal using Ctrl-Alt-F7).

If you can login there, shut down the X server with sudo /etc/init.d/gdm stop. Then you can use Aptitude, apt-get or other commandline tools to locate and uninstall the proprietary NVidia drivers, or try to reconfigure them to get them working. Test your changes with the startx command (remember, X runs on vt7, so if you need to switch back to the text console use Ctrl-Alt-F1). Once you've gotten it working you can resume normal GDM functionality by rebooting or by running sudo /etc/init.d/gdm start.

You can boot straight to a commandline with the 'recovery' entry in the Grub boot menu. This will boot to a maintainence mode, allowing you to login as root and perform any system operations as needed.

share|improve this answer
Ctrl+Alt+F{1-6} seem to "work" but the screen is flickering so bad (I also noticed the lights on my keyboard are flashing at the same rate - caps lock, num lock, etc so I guess the whole of X server is restarting) it's impossible to type. – Christopher Lightfoot Oct 17 '09 at 20:24
vt1-6 shouldn't have anything to do with the X-server. maybe the nvidia driver you installed is conflicting with the console framebuffer. see if booting to the recovery option gets you a stable console. – quack quixote Oct 17 '09 at 20:28
I thought that too but had same experience with nv and Nouveau drivers. – Christopher Lightfoot Oct 18 '09 at 9:08
I couldn't find out how to get grub to load, Seems they disabled it to increase boot tim? – Christopher Lightfoot Oct 18 '09 at 9:09
Disabled the menu rather, not grub itself :-p – Christopher Lightfoot Oct 18 '09 at 9:09

i'm getting the same flashing screen. What I do on my Dell D610 to stop the flashing is to restart the computer and press Escape (ESC), then boot to the kernel in recovery mode. That stops the flashing and I can use the command line with no problem at all.

share|improve this answer
Yep, This was a couple weeks before the official release - back then there was no interactive boot, GRUB just continued without letting me hold escape :(. I've not tried it since but I'm guessing this has been changed. – Christopher Lightfoot Nov 20 '09 at 12:24

The following worked for me

  • When grub starts loading hit Esc
  • Select "(recovery mode)" from the boot menu
  • Select netroot from the Recovery Menu
  • Edit /etc/X11/xorg.conf and add 'Driver "sis"' to the Device section.
  • reboot

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .