Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I'm still pretty new to Python so I don't understand all the package and module setups on my computer yet, but I had what I'll consider a good setup because everything was working fine. There were some modules I wanted to use and the easiest way it seemed I read was to use the EPD Free package. I downloaded it, installed it, and now some of the modules and toolkits I was using have stopped working. It also upgraded Python from 2.7.2 to 2.7.3. Is there a way to uninstall EPD Free and go back to my original setup?

share|improve this question

migrated from stackoverflow.com Mar 16 '13 at 2:08

This question came from our site for professional and enthusiast programmers.

    
Python keeps a separate set of packages for each python distribution you install. Have you tried reinstalling the packages using the EPD python? OR, I'm guessing your original python installation still exists... check your filesystem. If you launch python using the original installation, do the packages work again? –  SethMMorton Mar 15 '13 at 18:22
    
have you considered use pip uninstall? –  Fernando Freitas Alves Mar 15 '13 at 18:33
    
pip uninstall won't work for EPD, which is the Enthought Python Distribution, a complete python distribution that includes matplotlib, numpy, scipy, and a few others. My guess is when he calls python, it calls the EPD python binary, which looks in its own library. Therefore, the old packages he had aren't found. If he installs the packages using the EPD python, they should be found when python is launched because they will be in the EPD python library. –  SethMMorton Mar 15 '13 at 18:39
    
Yes I tried reinstalling the original modules and toolkits I was using and am getting errors on some of their items. How do I launch python using the original installation and how do I do pip uninstall for the epd? Do I need to navigate to its directory for it do work? –  user1330225 Mar 15 '13 at 18:42
    
Nevermind. Figured it out. Thanks guys. –  user1330225 Mar 15 '13 at 19:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.