Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I boot in windows I get two option in the boot menu: Windows 7 and Ubuntu. The Ubuntu option was installed by Wubi as I had installed Ubuntu using it. But since then I have uninstalled Ubuntu using Wubi, but the option still remains.

I have tried to remove this option manually using bcdedit, but has failed so far.

Running bcdedit in the cmd prompt give the following output:

Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=V:
path                    \bootmgr
description             Windows Boot Manager
locale                  en-US
default                 {e58e9c4c-dc5b-11e1-be69-bb3b6bb64ef4}
displayorder            {e58e9c4c-dc5b-11e1-be69-bb3b6bb64ef4}
bootsequence            {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 3

Windows Boot Loader
-------------------
identifier              {e58e9c4c-dc5b-11e1-be69-bb3b6bb64ef4}
device                  partition=C:
path                    \WINDOWS\system32\winload.exe
description             Windows 7 Ultimate (recovered) 
locale                  en-US
recoverysequence        {e58e9c4d-dc5b-11e1-be69-bb3b6bb64ef4}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \WINDOWS

According to it, there should only be one option named "Windows 7 Ultimate (revovered)". But in reality the boot manager shows two options, Windows 7 and Ubuntu.

I also tried setting the timeout to 0, but no change could be seen on the boot screen.

EDIT: I have also tried msconfig, but it also says there is only one entry for "Windows 7 Ultimate (revovered)" when in fact, Windows Boot Manager shows two.

share|improve this question
    
Ankit, you must first make protected system files visible using either the options in the explorer or the attrib command in the command prompt. –  Arie Mar 16 '13 at 12:07

1 Answer 1

BCD edit is correct. This is a known bug with wubi

  1. Type msconfig in RUN or start menu search box and press Enter. It'll open System Configuration Utility window.

  2. Now go to "BOOT" tab.

  3. Delete any entry relating to Ubuntu.

  4. Make sure that Windows 7 is set as the default OS.

Since this does not help you,

You may need to boot into windows 7 recovery or boot from an install disc

Choose keyboard and click Next > Use recovery tools… and click Next > choose Command Prompt and then do bootrec /rebuildbcd (scans for other OS’s, unlike rebuildbcd it allows you to select the OS’s you want to add to bcd)

Finally,
You may want to consider a 3rd party alternative like EasyBCD neosmart.net/EasyBCD

There is a freeware version available with registration.

share|improve this answer
    
There is only one entry in msconfig. This is what confuses me. Both bcdedit and msconfig tell me that I have one entry when in fact there are two. –  Ankit Mar 16 '13 at 2:55
    
time to do a bootrec /rebuildBCD from the windows recovery environment. Please see edits in answer. –  G Koe Mar 16 '13 at 3:11
    
Can you explain it in detail, a simple bootrec /rebuildBCD does nothing. I tried doing it following instructions from this page : pcsupport.about.com/od/fixtheproblem/ht/… but I faced a problem that there is no file named c:\boot\bcd. Specifically, I do not know where is the system BCD Store located. –  Ankit Mar 16 '13 at 3:27
    
You need to boot into Windows recovery environment, either from a recovery disc, install media, or an installed recovery partition. Using Bootrec could cause your PC not to boot, so PLEASE weight the value of removing this unwanted boot entry against the possibility that your PC will not be able to boot. support.microsoft.com/kb/927392 –  G Koe Mar 16 '13 at 3:29
    
But there is no file c:\boot\bcd –  Ankit Mar 16 '13 at 3:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.