Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just recently I noticed I couldn't FTP to my site. Then I tried to just go to my site. It didn't work. I decided to wait a day to see if the problem fixed itself. So the next day at school tried going to it on my phone, and it worked. When I got home, it didn't. I think it may be a problem with my DNS. I did nslookup and it said this:

> chattle.tk
Server:  www.asusnetwork.net
Address:  192.168.1.1

Non-authoritative answer:
Name:  chattle.tk
Address:  31.170.167.58

The thing is, its worked before. It just randomly stopped, and i didn't install any new firewalls or proxy's or anything.

share|improve this question

migrated from serverfault.com Mar 16 '13 at 9:07

This question came from our site for system and network administrators.

1  
Did you try a DNS lookup at school to see if it was different from at home? –  Ladadadada Mar 14 '13 at 23:12
    
Was your phone on the school's wifi? –  Jason Sperske Mar 14 '13 at 23:16
1  
No, I was just using data. –  Travis Nabbefeld Mar 14 '13 at 23:24
    
Oh, and I contacted my web host, and he said he could connect to it from where he was. –  Travis Nabbefeld Mar 14 '13 at 23:30
    
Non-authoritative answer just means the DNS server that returned the answer isn't authoritative for the domain, which in your case looks like your local gateway/router (192.168.1.1) - this is normal. The registered nameservers for your domain (ns1.freehostingnoads.net) do return an authoritative answer, which has the same IP as above. So unless you are getting a different answer in different places then it's not a DNS problem (also if you can view the site in a browser but not FTP then it's not DNS for certain). Possibly some firewall setting that blocks FTP? –  Dave C Mar 14 '13 at 23:46

3 Answers 3

Try running a DNS trace from the two different locations and compare the results. Maybe there's a misconfigured DNS somewhere.

dig chattle.tk +trace 

If it fails from your university, try using Google's DNS server (8.8.8.8) to make sure your SOA is working fine at that time.

$ dig chattle.tk +trace @8.8.8.8

; <<>> DiG 9.8.1-P1 <<>> chattle.tk +trace @8.8.8.8
;; global options: +cmd
.           20377   IN  NS  b.root-servers.net.
.           20377   IN  NS  d.root-servers.net.
.           20377   IN  NS  c.root-servers.net.
.           20377   IN  NS  m.root-servers.net.
.           20377   IN  NS  j.root-servers.net.
.           20377   IN  NS  k.root-servers.net.
.           20377   IN  NS  e.root-servers.net.
.           20377   IN  NS  h.root-servers.net.
.           20377   IN  NS  a.root-servers.net.
.           20377   IN  NS  g.root-servers.net.
.           20377   IN  NS  f.root-servers.net.
.           20377   IN  NS  l.root-servers.net.
.           20377   IN  NS  i.root-servers.net.
;; Received 228 bytes from 8.8.8.8#53(8.8.8.8) in 199 ms

tk.         172800  IN  NS  a.ns.tk.
tk.         172800  IN  NS  b.ns.tk.
tk.         172800  IN  NS  c.ns.tk.
tk.         172800  IN  NS  d.ns.tk.
;; Received 271 bytes from 193.0.14.129#53(193.0.14.129) in 114 ms

chattle.tk.     300 IN  NS  ns2.freehostingnoads.net.
chattle.tk.     300 IN  NS  ns1.freehostingnoads.net.
;; Received 84 bytes from 194.0.40.1#53(194.0.40.1) in 51 ms

chattle.tk.     86400   IN  A   31.170.167.58
chattle.tk.     86400   IN  NS  ns1.freehostingnoads.net.
chattle.tk.     86400   IN  NS  ns2.freehostingnoads.net.
chattle.tk.     86400   IN  NS  ns3.freehostingnoads.net.
chattle.tk.     86400   IN  NS  ns4.freehostingnoads.net.
;; Received 200 bytes from 64.191.115.234#53(64.191.115.234) in 119 ms
share|improve this answer
    
I tried using 8.8.8.8 as my DNS and it still didn't work. –  Travis Nabbefeld Mar 14 '13 at 23:56
    
please provide the output for: dig chattle.tk +trace and dig chattle.tk +trace @8.8.8.8 –  Gustavo Mar 15 '13 at 9:33

Port forwarding only works from the outside to the inside. You are trying to connect from the inside to the inside using a destination IP address that can only work with port forwarding. These two requirements are contradictory.

Unless you're using loopback NAT (sometimes called hairpin NAT, a form of dual NAT), you cannot access a server using its public IP address from the same private network that the server is on. The router has no opportunity to NAT the return packets, which causes them to have the wrong source address when they are received.

See this answer for a walkthrough of how it fails.

share|improve this answer
    
I'm not on the same network as the server. –  Travis Nabbefeld Mar 15 '13 at 1:01
    
And it doesn't work from any machine on your network? –  David Schwartz Mar 15 '13 at 1:57
up vote 0 down vote accepted

Its ATT&T blocking the ip's of the servers. Not much I can do about that:(

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.