Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a system that boots BeOS and Haiku nightly, and has a spare partition which I used to have PC-BSD booting on. (I use Haiku's BootManager on .../master/raw.) I want to try Linux Mint 14, but I don't have a spare USB stick and my drive only burns CDs and the Mint download was 800-900MB.

While the BSD partition was still marked as FreeBSD-type, I had used this (in Haiku) to copy the iso overtop of it:

dd if=/boot/home/Desktop/linuxmint-14-xfce-dvd-32bit.iso of=/dev/disk/ata/0/master/3 bs=1M oflag=direct

When I try to boot to it, the first thing it says is something about a missing or corrupt isolinux.bin, even though under Haiku I can mount the new partition and see that file just fine. (It says it once and then looks like it tries to network boot--I'm not sure if that's Mint's bootloader trying that or my BIOS.)

I then tried using BeOS' DriveSetup to reinitialize the partition to FAT32 and copy over it again with the above dd command in Haiku (I would have used dd in BeOS but it didn't support oflag.) Exact same result.

How can I get this working from just this system, without a USB stick nor burning anything?

share|improve this question
Why don't you buy usb stick, they are very cheap and the easiest way. – blogger Mar 16 '13 at 10:35
Donations accepted... :) – Kev Mar 16 '13 at 14:12
Isn't unetbootin working on harddrive partitions? – FSMaxB Mar 18 '13 at 16:48
Don't think it runs on Haiku/BeOS though – Kev Mar 18 '13 at 20:26
My friend sucessfuly installed even windows 7 with unetbootin, all you need is iso to make bootable usb stick – blogger Mar 29 '13 at 16:33

You must log in to answer this question.

Browse other questions tagged .