Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In WindOS 7 x64, MSU file type is associated with WUSA.exe under System32 folder.

I made a big mistake by changing it to Explorer.exe under Windows folder.

Now, I cannot revert back the file association permanently. The Always use the selected program to open this kind of file checkbox is disabled under Open with | Choose default program.

I tried to delete the registry entry (HKCR | .msu) but no luck.

Is there any fix for it (other of reinstalling Windows)?

share|improve this question
add comment

1 Answer

The Windows Registry contains a list of all the file associations, specifically the "HKEY_CLASSES_ROOT" section. Deleting the entry will not fix the issue as that makes it not connected to anything. What I think you need to do is set the key(s) back to its original values.

BTW I exported the key for the .MSU key from my Windows 7 Home Premium computer which should still be at the default value. Should be able to plop this into Notepad and save it with a .REG and then run it:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.msu]
@="Microsoft.System.Update.1"

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1]
@="Microsoft Update Standalone Package"
"FriendlyTypeName"=hex(2):40,00,22,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,\
  00,72,00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,\
  33,00,32,00,5c,00,77,00,75,00,73,00,61,00,2e,00,65,00,78,00,65,00,22,00,2c,\
  00,2d,00,31,00,30,00,32,00,00,00

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1\CurVer]
@="Microsoft.System.Update.1"

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1\DefaultIcon]
@=hex(2):22,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,\
  00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,77,00,\
  75,00,73,00,61,00,2e,00,65,00,78,00,65,00,22,00,2c,00,2d,00,31,00,30,00,31,\
  00,00,00

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1\shell]

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1\shell\open]

[HKEY_CLASSES_ROOT\Microsoft.System.Update.1\shell\open\command]
@=hex(2):22,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,\
  00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,77,00,\
  75,00,73,00,61,00,2e,00,65,00,78,00,65,00,22,00,20,00,22,00,25,00,31,00,22,\
  00,20,00,25,00,32,00,20,00,25,00,33,00,20,00,25,00,34,00,20,00,25,00,35,00,\
  20,00,25,00,36,00,20,00,25,00,37,00,20,00,25,00,38,00,20,00,25,00,39,00,00,\
  00
share|improve this answer
    
Tried that. Unfortunately, it didn't permanently changed the association and the Always use the selected program to open this kind of file checkbox is disabled. –  vulcan raven Mar 17 '13 at 9:07
    
@vulcanraven: Try the extended registry export above and see if it helps. –  Karan Mar 18 '13 at 20:07
    
@Karan, still the same and the checkbox is disabled. –  vulcan raven Mar 19 '13 at 11:32
    
@vulcanraven: You shouldn't need the Always use the selected program to open this kind of file checkbox since the registry edit ought to have set the association back to defaults. After importing did you reboot and then try running an MSU file? Odd it didn't work; I can't see anything else related to .MSU association in the registry. –  Karan Mar 19 '13 at 17:57
    
@Karan, yes I did and its still associated with explorer. –  vulcan raven Mar 20 '13 at 9:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.