Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Excel Add-In saved to an .xla file in %appdata%\Microsoft\Addins. In the subject version of Excel it is checked on the Add-Ins list. One thing this addin does is create a drop-down menu in ThisWorkbook's Workbook_Open sub. But the menu is not created and there is no Add-Ins tab on the ribbon. No error messages.

This works fine in Excel 2010 and 2007 (at least), and worked fine on the 32-bit Excel 2013 that came preinstalled on this system before I nuked it. The really maddening thing is that if I get rid of this addin and open that same .xla file, either by double-clicking or using the Open command in Excel, the menu appears as expected. I get the same behavior if I instead open the source .xls file - it all works. I've also tried saving to a .xlam file instead of .xla, but get the same bad result.

Any ideas?

share|improve this question

5 Answers 5

As far as I know, if your add-in was created by an older framework such as .net framework 2. It will not work on Excel 2013 64 bit.

share|improve this answer

You need to check with whoever created the add-in to see if it supports 64-bit Office. MS themselves recommends 32-bit Office for most people largely because of compatibility with 3rd party add-ins. http://office.microsoft.com/en-us/excel-help/choose-the-32-bit-or-64-bit-version-of-office-HA010369476.aspx.

share|improve this answer

I have just experienced a similar problem with an Excel xlam file that is loaded at startup (XLStartup directory) which creates a custom menu (using CommandBarControls). The xlam works fine in Excel 2007 and 2010, and until recently in 2013. The xlam code will create the custom menu if loaded manually after startup.

Debugging during startup by stepping through the code and setting test points indicates that the code is being executed correctly and without errors, but not menu is created - statements are ignored. It appears that when attempting to create the custom menu, the framework (i.e. Ribbon) has not yet been loaded by Excel, so the menu is not created.

If I convert the xlam to a xlsm file and place it in the XLStartup directory, then the custom menu is created. However, this leaves the xlsm file visible to user (hence why I would prefer to use the xlam format).

share|improve this answer

Have you tried to open Excel as an Administrator? You need to hold the Shift key and while holding it right-click on the Excel program icon and then select Run as administrator.

From my experience Add-in tab is not displayed when the user does not have permission to run the installed add-ins.

share|improve this answer

I've found a workaround for this. Disable the Analysis Toolpaks. Restart Excel and now all your add-ins will load. Not sure why.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.