Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with time when booting windows after linux. The reason is that Ubuntu saves hw clock as UTC but Windows 7 expects it to be saved as localtime. So Windows shows time that is one hour before correct local time.

  • UTC time: 3:35PM
  • Local time (UTC+1): 4:35PM
  • Ubuntu time: 4:35PM
  • Windows time: 3:35PM (it shows time that equals to UTC because it expects hw clock to be localtime)

I followed this advice:

To make MS Windows calculate the time from the hardware clock as UTC. Via regedit: Run regedit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation Right-click in the right-side panel and select New > DWORD Value. Create the key named RealTimeIsUniversal and give it a value of 1.

After restarting, windows shows time that is 1 hour ahead. My timezone is UTC+1 but time is set to UTC+2. If I set timezone to UTC, time is correct.

  • UTC time: 3:35PM
  • Local time (UTC+1): 4:35PM
  • Ubuntu time: 4:35PM
  • Windows time: 5:35PM (it shows time that equals to UTC+2 but timezone is set to UTC+1)

Setting ubuntu to save hw clock as localtime solves the problem with time but I want to have hw clock set to UTC.

Any suggestions?

Thx in advance and sorry for my bad english :)

share|improve this question

migrated from stackoverflow.com Mar 16 '13 at 18:16

This question came from our site for professional and enthusiast programmers.

    
This may be a dumb question, but did you verify in Windows there is no daylight savings setting? That would account for an hour. Sorry, my only idea! –  nerdwaller Mar 16 '13 at 20:46
    
Yes, I did but that is not the problem... Finally, I found a solution. It is very easy. After I had changed settings in regedit and restarted the pc, Windows wrote localtime to hw clock. After booting to windows, it started to use UTC so time was wrong. I just needed to boot linux that wrote UTC time to hw clock and then boot to windows and time is correct. –  darthcz Mar 16 '13 at 23:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.