Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading to Snow Leopard have been having the following problem:

When I go to bed, I set my mac to play an iTunes internet stream. I set the Dashboard widget "Minutes" to sleep my computer after one hour or more. I did this procedure all of the time under Leopard and there were no problems. However, in Snow leopard, the computer doesn't go to sleep anymore. The timer in minutes counts down to zero and the computer doesn't go to sleep. If I set the timer on a shorter time period (like 15 minutes), the mac will sleep. I have also tried other dashboard widgets such as Shutdown Timer and they also have the same problem.

Has anyone had this problem? Any suggestions?

Macbook Unibody Late 2008 Mac OS X (10.6.1) C2Duo 2 GHz

share|improve this question

Is it important to use a widget ? If not you can take a look at the shutdown command.
In the Terminal : sudo shutdown -h 10:30 will shutdown the Macbook at 10:30.

share|improve this answer
up vote 0 down vote accepted

Thank you so much for your responses.

I'd prefer that the computer would go to sleep so that it can wake me up in the morning (and not require me to login).

I believe that I've determined what the issue is on my computer anyway. I turned off the "require password after sleep and screen saver" function and now it goes to sleep correctly. I guess the widget was unable to sleep my MB when the password window was being displayed.

Thank you for your help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.