Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an 18-month old Lenovo L520 (model 7859). It is extremely laggy in Windows 7, sometimes lagging up to 10 seconds before responding to a click or keystroke. (There are times when it will go minutes without delay, but the problem is fairly prevalent while using the computer).

It also occasionally produces a BSOD, reporting BUGCODE_USB_DRIVER. There are no external USB devices connected to the system.

Here are some things I have already done to troubleshoot this problem:

  • Restored to factory configuration (several times). Problem appears on the machine immediately after installing from Lenovo recovery partition; no third-party software is required to produce the problem other than perhaps some of what comes with the system.
  • Removed most of the pre-installed non-Microsoft software. No effect.
  • Checked to make sure the BIOS is already newer then version 1.15 and the controller is set to AHCI mode, per this techote: http://support.lenovo.com/en_EG/downloads/detail.page?DocID=HT062964. Unfortunately, although this seemed promising, the BIOS is already in good shape.
  • Looked at various system monitoring tools. As far as I can tell, the problem is nearly-constant (or at least, extremely frequent) disk access, but I can't tell what process is causing this access or how to avoid it. Neither RAM nor CPU are constrained.
  • Tried running the computer using Ubuntu on a USB key. The problem DOES NOT appear when booted into Ubuntu on a USB key, leading me to strongly believe this is a software problem.

The computer is usable, kind of, but it definitely isn't performing at a level I'd expect from similar hardware. Unfortunately this wasn't reported to me until the system was out of warranty (although the problem has definitely existed from the day we bought the machine), so making it Lenovo's problem wasn't something I could afford to do. I don't have any other computers of exactly the same model to compare with (though I have some that are quite similar, which do not have this problem).

What should I try next?

share|improve this question
    
What size is the hard drive and how much free space do you have? –  Carl B Mar 16 '13 at 20:26
    
300 GB drive, 225 GB free. –  davidcl Mar 16 '13 at 20:33
    
that rules out crampped free space on the drive. –  Carl B Mar 16 '13 at 20:37
    
zip and upload the dmp files. –  magicandre1981 Mar 17 '13 at 6:17
add comment

2 Answers

up vote 1 down vote accepted

It would make sense to address the BUGCODE_USB_DRIVER - BSOD error. It would at least eliminate that from the equation and it may be related to the performance issue.

Suggest going to control panel and uninsatalling all items in USB controllers: Goto system > device manager then click the plus next to universal serial bus controllers. Right click on each one then select uninstall. After uninstalling all of them reboot and let windows reinstall the usb drivers.

share|improve this answer
    
I think you might be on to something. I uninstalled them, haven't rebooted yet, but since the uninstall-- no lag. The only two hardware devices that were being supported by USB were bluetooth and fingerprint reader, and I do not use either one. –  davidcl Mar 17 '13 at 19:42
    
After the reboot, if the lag returns, I may just try uninstalling the bluetooth and fingerprint drivers... –  davidcl Mar 17 '13 at 19:42
    
Interestingly, they detected the hardware and reinstalled themselves before rebooting... I didn't know that would happen! I've disabled the drivers for the bluetooth radio and fingerprint sensor. I'm going to give it 24 hours to make sure this solves the problem, but it is looking good so far. –  davidcl Mar 17 '13 at 23:35
    
That is good news. It may have been a corruption of some kind and uninstalling/reinstalling could address the issue. –  Carl B Mar 17 '13 at 23:45
    
Sadly, this wasn't a permanent solution, but I'm pretty sure it's in the right neighborhood. Since I have a different computer now, I've given up on using this one with Windows-- just using it with Ubuntu now. –  davidcl Dec 31 '13 at 18:07
add comment

Try a hard drive diagnostic test. Thats all thats left that the USB Ubuntu could not address. After that I would try a clean install without factory restoration. I personally use Ultra-X to diagnose hard drives but I don't know if your repair is worth a $400 diagnostic utility. There is all ways the hard drive manufactures utility.

share|improve this answer
    
No, not worth a $400 diagnostic utility; the computer's barely worth $400 at this point even if it were performing correctly. –  davidcl Mar 16 '13 at 19:33
    
pcsupport.about.com/od/toolsofthetrade/tp/tophddiag.htm This has some of the manufacturer diagnostic software. –  NoNo Mar 16 '13 at 19:36
    
I've got a Toshiba drive. Other than scandisk/chkdisk, which I've already run, it appears that none of those will work for my drive. (I know it says the Hitachi utility will work with non-Hitachi drives but I tried it and it doesn't appear to work). –  davidcl Mar 16 '13 at 20:12
    
I ran the Lenovo hard drive diagnostic, and it came back with nothing wrong. –  davidcl Mar 17 '13 at 23:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.