Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to have a VMware Fusion desktop go full screen in a Space (as in Spaces Space, the virtual desktop thing) other than the space the application was open in?

When I'm using a VM I prefer that it stay off screen in the second Space. I also prefer that it operate in full screen mode, since mouse interactions are less wonky, and I'll less likely to accidentally pop out of the machine.

However, occasionally when I'm using two monitors at home (this is with a laptop), I'll mindlessly open VMWare in the main Space and then work for a while with the VM full screen on the second monitor, but still in the first space. Then when I leave home with the laptop, my VM is stuck in Space 1.

Is there anyway to get the VM to go full screen in another space other than restarting VMware? I've tried moving the windowed VM to another space and going full screen, but the OS will return the main space and the full screen VM will come up there, not in the Space I dragged it to.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

What you can do - is before disconnecting your monitor is:

  • Active spaces and simply "drag+drop" the full screen VMware App onto your 'main/laptop' space equivalent.

Once you disconnect the screen - VMware will be on the remaining monitor - and you won't have this issue.

That's what I do when going between Office + Home.

Let me know if you want more details.

share|improve this answer
    
You misunderstood. I always want my VMWAre in a different space. Sometimes I start using it in the main space, and then I can't get it in another space. –  Alan Storm Oct 24 '09 at 17:11
    
I understand that bit. You will have no problem in moving VMware 'fullscreen' in Spaces mode, once you have the monitor disconnected, and it will stay in that mode. The key is moving it with the Spaces-overview activated (Fn+F8). –  romant Oct 25 '09 at 8:45
    
AH ha, my misunderstanding. I never use spaces in the "active a space" way, I always use it with the arrow keys. Activating the expose style spaces and then dragging the application did the trick! –  Alan Storm Oct 27 '09 at 21:14

You can't generally get an app to go from a window on one space to fullscreen on another space (there aren't really public APIs in Leopard/Snow Leopard to control that type of behaviour).

If the VM seems be 'jumping back' to some other space when it goes to fullscreen it's probably because the Fusion Library window is on that space. Put the Fusion 'VM Library' window on the space where you want your VM to be fullscreen (it will get obscured by the fullscreen VM - but you probably don't need to interact with it much anyway ?).

If you have a dual-monitor system then you can have a fullscreen VM occupy on a single (or both - it's a preference) monitor when fullscreen. So you could put the Library window on one monitor in Space N and the VM window on the other monitor in Space N and then have the VM go fullscreen - it will occupy all of the monitor it started on and should stay in Space N (because that's where the library window is).

You can also use the spaces preferences to associate the Fusion app with a given space. So it always starts up there. That's generally how I work (fullscreen or windowed) - I have Fusion on space 3 and email/browsing etc on Space 1.

share|improve this answer
    
Moving the library window doesn't help. The Virtual Machine still jumps back to the space it was opened in. –  Alan Storm Oct 24 '09 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.