Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine that I use to open up a SOCKS connection using Putty on SSH. I set the tunnel to Dynamic localhost 8080 which I can use locally.

How do I get a machine on the local network to access and able to use that proxy?

Under FireFox settings for network on the SOCKS settings I tried and entered 192.166.2.2:8080 for the local computer that has the open connection. Do I need to do something else?

share|improve this question

migrated from serverfault.com Mar 16 '13 at 20:07

This question came from our site for system and network administrators.

2 Answers 2

on your server run powershell as admin and run

 netstat -abo | findstr LISTENING | findstr :8080

note the IP address associated with :8080. is it 127.0.0.1, 192.168.2.2,or0.0.0.0? My hunch is the ip address is 127.0.0.1, which means that the port is only available to the localhost. try adjusting your socks proxy to use 192.168.2.2 instead of 'localhost'.

share|improve this answer

You have to enable the checkbox "Local ports accept connections from other hosts" in PuTTY's Tunnel settings:

Screenshot PuTTY

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.