Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried the 64bit version and found I was constantly hitting a brick wall trying to get 32bit stuff to run; I'd previously used PAE on 9.04 without any issues so figured I'd give it a shot.

However, on 9.10 it seems PAE or the process of enabling PAE breaks the nvidia drivers/module somewhat as performance is terrible; I can't even enable desktop effects and there's lots of artifacting on random controls.

Disabling the pae image and rebooting fixes the issue however I'm then stuck with "only" 2.7Gb of ram and unable to use the full 8gb that's installed.

Is there somthing special I need to do when using pae and nVidia drivers or should I be using 64bit and just figure out how to force run 32bit packages? :-p

share|improve this question
    
...heh. nVidia should be one of the tags on this. – pbr Nov 13 '09 at 1:26
    
PAE really really sucks - said Linus Torvalds. It's not a good solution phoronix.com/… – Lưu Vĩnh Phúc Mar 15 at 11:37

A comment on a PAE how-to post indicates you need to disable the restricted driver, then install the PAE-enabled kernel, reboot, then re-enable the restricted driver. This was from pre-9.04 but sounds like general PAE advice. Is this the procedure you used when installing your PAE kernel?

share|improve this answer
    
No. I did notice that when enabling/disabling pae depmod(?) rebuilds the modules... I'll see if the reboots in between work. – Christopher Lightfoot Oct 17 '09 at 21:42

Are you sure that enabling PAE is limiting your available memory? http://www.cyberciti.biz/faq/ubuntu-linux-4gb-ram-limitation-solution/ seems to indicate the reverse...

share|improve this answer
    
Also take a look at linuxforums.org/forum/slackware-linux-help/… – pbr Dec 3 '09 at 22:41
    
PAE works fine; It just breaks the nVidia driver. – Christopher Lightfoot Dec 11 '09 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .