Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After opening the cmd.exe as usual, I suddenly see a weird thing: every output of any command that I enter that is related to my dev environment (ruby, git) in the cmd window is prefixed with the text: flashplayerplugin.

Interestingly, regular windows commands such as ver, dir work normally.

I uninstalled any flash plugins I had and restarted Windows, I also ran CCleaner cleaning any garbage I had and fixing registry entries. Didn't help.

See screenshot here:

enter image description here

Any idea what's going on and how to fix it?


My setup: Windows 7 on laptop.
My dev environment: RailsInstaller (Ruby 1.93, Rails 3.2), Git 1.7, RubyMine

share|improve this question
1  
Try and enter the command set to list all the environment variables. Does the problem occur with Powershell? –  Pincopallino Mar 17 '13 at 9:36
    
SET works fine, no hint of any unusual params here. Powershell works fine as well –  Mike Marsian Mar 17 '13 at 10:26
    
Have you tried an sfc /scannow for checking the system files? –  Pincopallino Mar 17 '13 at 11:07
    
Ran sfc /scannow - no errors were found –  Mike Marsian Mar 17 '13 at 14:44
    
Any chance you're using chocolatey? One thing I did today (which may be totally unrelated) is do a cinst mongodb –  Josh Kodroff Mar 20 '13 at 23:11

3 Answers 3

up vote 2 down vote accepted

After burning almost a day on this I eventually found a solution:

Using PowerGrep (grep for Windows) I found that I had 2 installations of Flash plugin player: 32 bit version (which I of course removed), and 64 bit version, of which I had no idea. Uninstalling the 64bit version and restarting the system fixed the issue.

share|improve this answer
    
I've uninstalled the Flash player that installed yesterday, guessing that's the 64-bit version. Where did you find the 32-bit version and how did you remove it? Just deleted a folder? I don't see an entry in Programs for it. –  Tom Mar 19 '13 at 13:16
    
I used Power Grep to search for flashplayerplugin string in files - that's how I found it (don't remember the exact location, but I remember it was under Macromedia folder). Regarding the uninstall, it had uninstall executable in the same place where the flash was located. –  Mike Marsian Mar 19 '13 at 13:23

I hate to leave this dead end for anyone else who comes to this question, but Mike Marsian's solution didn't work for me and I wound up using a System Restore to get me back to yesterday morning (and for once System Restore worked). I think my problem might have been that Chrome has its own copy of Flash. I actually discovered the problem wasn't unique to me via a conversation on Twitter with SourceTree if that provides any leads for people.

For anyone who winds up here, there's a similar Stack Overflow thread.

share|improve this answer

The problem for me was a registry key added by AirFoil. Following the solution here worked: http://stackoverflow.com/questions/15467295/java-sdk-manager-crashes-with-flashplayerplugin-in-the-input

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.