Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am just trying to install linux mint 14 on my desktop and it's booting into live cd, but when I try to install its partitioning step it's not showing my partitions.

If I use sudo fdisk -l it shows as:

mint@mint ~ $ sudo fdisk -l

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xbe8c983f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   204812684   102302918+   7  HPFS/NTFS/exFAT
/dev/sda3       204802046  3907024064  1851111009+   f  W95 Ext'd (LBA)
/dev/sda5      2228745708  2857883174   314568733+   7  HPFS/NTFS/exFAT
/dev/sda6      2857883238  3277308194   209712478+   7  HPFS/NTFS/exFAT
/dev/sda7      3277308258  3907024064   314857903+   7  HPFS/NTFS/exFAT
/dev/sda8       204802048   218081343     6639648   82  Linux swap / Solaris
/dev/sda9       245041152   666245119   210601984   83  Linux
/dev/sda10      666247168  2228744191   781248512   83  Linux

Partition table entries are not in disk order

However, neither the installer nor gparted show me these partitions:

enter image description here

Note: I have successfully installed it on my laptop (dell xps 15z) yesterday and it works fine (I especially loved my trackpad working :D).

Note: I can browse around partitions in live cd, can play videos, open anything.

share|improve this question
    
Could you post a screenshot of gparted? What does it show? Is it reading another hard drive? –  terdon Mar 17 '13 at 13:34
    
I am not allowed to upload images so I cannot post one, but I can write the text show on gparted screen 'Device | Type | and so on /dev/sda and at "Device for boot loader installation: /dev/sda ATA SAMSUNG HD204UI (2.0TB)' Hope it helps –  Syed Mar 18 '13 at 10:38
    
So gparted sees sda but no partitions on it? Try uploading the image somewhere (like imageshack.us for example) and link to it in your question. –  terdon Mar 18 '13 at 11:27
    
Here is the link –  Syed Mar 18 '13 at 12:06

1 Answer 1

Here's your problem:

   Device Boot      Start         End      Blocks   Id  System
/dev/sda2          206848   204812684   102302918+   7  HPFS/NTFS/exFAT
/dev/sda8       204802048   218081343     6639648   82  Linux swap / Solaris

Note that /dev/sda2's end point is 204,812,684, which is greater than the start point of /dev/sda8 (204,802,048). In other words, those two partitions overlap. (/dev/sda3, which is a placeholder for all your logical partitions, also overlaps with /dev/sda2.) Most libparted-based programs misbehave when presented with such problems. Showing the disk as entirely empty is one common specific misbehavior.

I recommend the following:

  1. Download and install my FixParts program. (It's part of the gdisk or gptfdisk package in many Linux distributions, so it might already be installed.)
  2. Launch FixParts on the disk.
  3. Type p in FixParts to view the partition table. Chances are either /dev/sda2 or /dev/sda8 will be marked as omitted under the Status column.
  4. Use the o, r, and l options, as necessary, to adjust the partitions' status so that /dev/sda8 is omitted, /dev/sda2 is primary, and all the other partitions are included as either primary or logical. Note that anything marked as omitted will be deleted when you save your changes; but FixParts doesn't save changes until you type w, so you can experiment all you like and type q to exit without saving your changes if you make a mess of things. The FixParts documentation (on the earlier link) describes how to make these changes in more detail.
  5. When you've adjusted your partitions as desired, type w to save your changes. The program will ask for confirmation. Give it.
  6. Boot into Linux and do a disk check on /dev/sda2 (which is probably C: in Windows). Since your Linux swap space overlapped the end of that partition, there's a significant risk that it's been damaged.

You should then be able to proceed with Mint installation. You'll probably want to create a new swap partition, since the preceding procedure deleted your existing swap space. If you've got another current Linux installation, you can edit its /etc/fstab file to use the new swap partition you create when you install Mint. (Two Linux distributions can share swap space, so long as you don't try to boot one after hibernating the other. If this is likely, having separate swap partitions for each distribution makes sense.)

It's possible to do this with fdisk or sfdisk, too, but you'd need to resize the surrounding extended partition (/dev/sda3), which FixParts does automatically.

Another approach is to find the size of the filesystem within the /dev/sda2 partition. If the filesystem is smaller than the partition, you could shrink the partition (using fdisk or sfdisk) so that it doesn't overlap with /dev/sda3 and /dev/sda8. I'm pretty sure there's a Linux tool that will give you NTFS size information, but I don't recall offhand which one it is. This approach will work only if the filesystem in /dev/sda2 is small enough that it ends before /dev/sda3 begins.

share|improve this answer
    
I see, I was suspecting it, but was not sure, I was thinking may be my partition table got corrupted some how, but got same warning (not sure where) about partition overlapping, I have linux mint 13 installed alongside windows 7 on my desktop and it was working, this is the cause it stopped working (my younger brother must have done something wrong :)). I will start by shrinking /dev/sda2 first and will see if it solves the problem (by using fdisk or hirenbootable cd (contains quite useful paritioning tools) and will update you. Thanks specially for pointing me to exact cause (I agree). –  Syed Mar 20 '13 at 9:59
    
I do NOT recommend shrinking /dev/sda2 with your current configuration! Given the overlap with /dev/sda3 and /dev/sda8, your partition table is invalid. This type of situation can wreak havoc with some programs -- I've seen partitioning tools trash all the logical partitions when they run into situations they can't handle. FixParts is almost certain to be able to cope with this, with the caveat that it might set up to omit the wrong partition by default, which will require manual intervention. I can't vouch for a random other tool, though. You might get lucky -- or not! –  Rod Smith Mar 21 '13 at 0:52
    
Thing is I am not much familiar with Fixpart, I read docs, was/is confused about how I can use it. So I took the other route, resized my partition /dev/sda2 but no luck, still invalid partition, then I deleted initial partitions (windows os partition and backup partition containing boot files and also deleted swap and old linux mint ext4 parition as well) means all beginning portion of my hard drive haaaaa, and it solved the issue (Though I initially tried several partition tools for fixing partition table, none worked).At-last I have installed linux mint 14 (nadia) successfully. Thanks. –  Syed Mar 21 '13 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.