Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Basically, I'm trying to install FFMPEG on a cPanel server. I'm able to get everything installed and working (tested using ffmpeg -v) except for libfdk-aac. I can do the git clone and everything just fine, but when I try to run autoreconf -fiv in the fdk-aac directory I get:

root@matrix [~/ffmpeg-source/fdk-aac]# autoreconf -fiv
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal -I m4 --output=aclocal.m4t
/usr/share/automake-1.11/Automake/ChannelDefs.pm line 23:

This Perl hasn't been configured and built properly for the threads
module to work.  (The 'useithreads' configuration option hasn't been used.)

Having threads support requires all of Perl and all of the XS modules in
the Perl installation to be rebuilt, it is not just a question of adding
the threads module.  (In other words, threaded and non-threaded Perls
are binary incompatible.)

If you want to the use the threads module, please contact the people
who built your Perl.

Cannot continue, aborting.

I've tried using Perlbrew to install a separate version of perl using the -Dusethreads and the -Duseithreads options, but nothing changes, same error.

The command I am using for installing using Perlbrew is: perlbrew --force install --as perl-5.16.3-t -Dusethreads -Duseithreads perl-5.16.3

Nothing seems to help. Is this even possible? Please don't tell me not to use cPanel, it's for a client and he needs it. :P

EDIT: The guide I'm using can be found here: CentosCompilationGuide

share|improve this question
    
Did you ever solve this? I'm trying to do exactly the same thing and haven't succeeded with getting it to recognise my perlbrew version of perl. There's hardly any information about libfdk-aac anywhere... I'd appreciate any insight. –  andrewthecoder Sep 19 '13 at 12:14
add comment

1 Answer

Terribly bad-practice solution, but I just solved this by following this section to build libfdk-aac on a new, clean, centos 6 virtual machine created specifically for this task:

cd ~/ffmpeg_sources git clone --depth 1 git://github.com/mstorsjo/fdk-aac.git cd fdk-aac autoreconf -fiv ./configure --prefix="$HOME/ffmpeg_build" --disable-shared make

then tarring the build folder, copying it to and extracting it on my cPanel machine, then running "make install" from inside it. That copied the library to my ffmpeg build prefix (since I kept the prefix the same when I built it on the virtual machine), so I was then able to configure and build ffmpeg properly with the fdk aac encoder.

If it's of any use, here is the tar archive of my libfdk-aac build, as described above, with the prefix set to ~/ffmpeg-build from the root account, therefore when "make install" is executed, it will copy the fdk aac library to /root/ffmpeg-build.

It should work fine for you, if you followed the entire Centos Compilation Guide from the root account. Let me know how it goes!

http://andrewbeveridge.co.uk/old/fdk-aac.tar.gz

UPDATE:

Actually, I just found centos rpms for fdk-aac, so installing these is probably an easier and better way to get ffmpeg to compile on a cPanel system, assuming it is 64 bit.

rpm -Uvh http://andrewbeveridge.co.uk/old/fdk-aac-0.1.1-1.el6.x86_64.rpm http://andrewbeveridge.co.uk/old/fdk-aac-devel-0.1.1-1.el6.x86_64.rpm
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.