Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought somedays ago a HP 650 Laptop which comes with DOS, 500GB HDD, 2GB RAM and intel graphics card. From the shop, they installed another 2GB of RAM. So total primary memory is 4GB of RAM. I installed Windows 7 32 bit. But now it is showing only 959MB usable and the laptop is working slow. What can I do now? Is there actually anything I can do to extend the RAM usability?

share|improve this question
    
Does it show all the RAM in the BIOS? Did you try taking the RAM they installed out to see if it behaves any differently? –  Ƭᴇcʜιᴇ007 Mar 17 '13 at 18:16
    
@techie007, Yes in BIOS, it shows 4GB too. No I did not risk taking the RAM out of it myself! Should I try it? –  Mistu4u Mar 17 '13 at 18:17
1  
Have you tried a memory test yet? Have you gone over questions like: Windows only sees 768 MB RAM out of 4 GB? If you just bought the notebook and RAM from the same place, then perhaps put a call into the shop? :) –  Ƭᴇcʜιᴇ007 Mar 17 '13 at 18:20
1  
Where precisely is it saying that 959MB is usable? –  David Schwartz Mar 18 '13 at 3:38
1  
@DavidSchwartz, In 'Control Panel\System and Security\System', in installed memory section. –  Mistu4u Mar 18 '13 at 3:42

4 Answers 4

First of all check if all the 4GB are actually recognized by your computer. Press Ctrl+Shift+Esc to open the task manager, then navigate to Performance tab, there you can find the total Physical Memory & the available memory and how much is used.
Then navigate to Processes tab and arrange the processes in descending order according to the memory used by each program, so you can know exactly which program is using the most memory, and act accordingly (eg. prevent that program from opening at startup ...etc)

And also try memtest on your RAM to make sure they don't have any problems.

share|improve this answer
up vote 1 down vote accepted

So finally I managed to solve the issue. Somewhere in the internet I read it can be the problem due to the Windows version installed being 32 bit and that Windows 7 with some specific hardware works good in 64 bit version. So I uninstalled the 32 bit version used and installed a 64 bit version and voila, the problem is solved. It is now showing 3.90GB usable RAM and the computer also became dramatically fast.

share|improve this answer

What should you do?

Unfortunately, what you should do is bring it back to the shop that you purchased it from. This is not a problem you should have to deal with under any circumstances, regardless of whether it is a simple problem to fix.

You don't know if the installation of Windows saw the whole 2gb originally, since you bought the laptop and had them install an additional 2gb before it was yours. In point of fact, everything should have been working correctly when you brought it home. To be blunt, everything should have been working correctly at the shop before you brought it home, and they should have shown this to you before you left their shop with it.

So, again... what should you do? Take it back, show them the issue, and have them fix it. Seriously. This isn't an end user issue. Yes, this issue might have developed if you had installed the memory on your own... but the longer you keep the laptop and try to fix it yourself, the greater the chance that the shop will refuse to fix it for free... which is what they should be doing, since obviously the unit didn't function correctly from the beginning.

Could it be a bad stick of Ram? Sure. Could it be an issue with the motherboard? Sure. Could it be some BIOS setting? Sure. What it definitely is, is not your issue to repair.

share|improve this answer

I have the same model. When I bought it, I also bought an extra stick of RAM. I took it all home, opened it up, installed the 2nd stick of RAM, closed it and turned it on. Windows didn't see the extra memory. I turned it off, opened it up again and checked the memory to find I hadn't pushed it in quite far enough. An extra push and it all worked fine.

Ultimatly Bon Gart is correct. The place of Purchase should be correcting this issue, not you. Take it back to them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.