Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something went wrong with our home computers boot files for Windows XP, thankfully we had all the files backed up but we no longer had the Windows XP installation CD to reinstall Windows XP. So I have downloaded Linux Mint as a new OS and have saved an image of the .iso to a dvd.

The computer now boots off of the DVD, however when I try and actually install Linux Mint it doesn't let me as apparently there isn't 6GiB free for it to install to.

When I open Disk Usage Analyzer it says the total file system capacity is only 1.9GiB of that there's none free, so I assume that's the DVD which Mint is booting off of.

When I open GParted it says: Libparted Bug Found! (as superuser) Invalid partition table - recursive partition on /dev/sr0

When I go to terminal, change the directory to dev and then enter ls sd* it says No such file or directory.

I'm lost as to what I need to do to get it to find the hard drive which is plugged in properly. I'm happy to completely reformat it and lose all data that's on there but I can't find it to do that!

Help me please and thank you. Could it be that mint doesn't like SATA hdds as in the first answer posted or something else?

share|improve this question
    
Since you're ready to lose all data, can you try DBAN and see if it can wipe the drive successfully? –  Karan Mar 19 '13 at 19:56
add comment

1 Answer

I have come across similar situations before. Here are two things to try.

The first thing would be to download and burn the Gnome Partition Editor. Boot off of it and see if you can erase the old partitions. If you can see the drive, you should be good to commit the changes and reboot off the Mint CD. If this doesnt work, most like the next step is the issue.

The second possibility is that Mint doesnt recognize your disk controller. Im going to assume its SATA since I ran into this issue several times with Fedora. I found Mint/Ubuntu had a larger driver base and liked the Mint interface better. You can attempt to find the right driver and/or compile it, but thats out of my scope of knowledge.

share|improve this answer
    
You're correct about it being SATA, also your first idea with the Gnome Partition Editor boot CD didn't work unfortunately and said "No devices detected". Thanks for your help though and same as you your other option is out of my scope of knowledge too. –  FlightOfGrey Mar 18 '13 at 3:21
    
In my case, a home-built i5 with Ubuntu Precise on it, the first solution (gparted-live-0.16.1.-1-i486.iso) worked marvelously. Many thanks much for this suggestion! –  Russ Bateman Jun 26 '13 at 5:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.