Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use PHP on my Mac.

If I were using Windows I would install WAMP server, but I'm not familiar with how to use PHP on Mac OS X. What kind of software should I use for installing/running my php developed sites locally on my Mac?

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

MAMP is the equivalent of WAMP for Mac OS X.

share|improve this answer
    
I would give you +5, if i could. –  Sagar R. Kothari Oct 17 '09 at 22:42
    
MAMP would be my first choice. Excellent program. –  Josh K Oct 18 '09 at 5:25
    
I think that MAMP is no longer a normal AMP stack (seems like it disallows virtual hosts in the free version?). Are there any alternatives? I found an "install mysql and you're done" here: echodittolabs.org/blog/2011/08/… –  Yar Mar 7 '12 at 5:06
1  
@Yar: Well, I suppose that's what you get for convenience. I'm not aware of any other application that does this, so your best bet would be to manually install and configure each part, like in the article you linked. –  Sasha Chedygov Mar 7 '12 at 6:55
    
Horrific. I might just run this stuff on Linux instead. At least that way I'm playing with one of the possible deployment platforms. –  Yar Apr 26 '12 at 4:44
add comment

PHP comes pre-installed in Mac OS X. It's not perfect for everyone (as it may or may not have the extensions you wish). To enable it (PHP 5.3 on Snow Leopard) you need to enable it in Apache 2's configuration file (Uncomment the php5.so module).

Applications such as MAMP provide a separate installation of the *AMP stack that work on Mac OS X.

Alternatively if you want to install other versions of PHP on your Mac you can either use MacPorts or compile it yourself.

From the way you are wording your question it sounds like you are not looking for how to use PHP on Mac OS X but how to set up the web development stack (Apache, MySQL, PHP) on your Mac.

share|improve this answer
    
Hey ! A great thing. On which version of Snow Leopard? A great Answer. You are aware of most of the things. –  Sagar R. Kothari Oct 17 '09 at 23:48
1  
Both Server and Client come with PHP 5.3. All versions of Mac OS X came with versions as well (Leopard had PHP 5.2, Tiger 4.3, even older versions not worth mentioning) –  Chealion Oct 17 '09 at 23:56
add comment

Marc Liyanage very kindly maintains a current build of PHP for Mac OS X at his website: http://www.entropy.ch/software/macosx/php/

Go there, download it, follow the installation instructions, and you're good to go.

share|improve this answer
add comment

You can try using mac ports. Although it is difficult to setup initially, but once setup, its very easy to add packages. You can install new servers/memcached/mysql/php just by few commands.

There are many articles on google on installing Macports and then installing AMP. I found this article helpful.

share|improve this answer
1  
Hi Saurabh, welcome to SuperUser. Your answer is pretty close to the one posted by Chealion from October 2009. I would suggest editing it to improve the quality and information on it. Take a look at the FAQ for some tips. –  user3463 Jul 31 '12 at 6:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.