Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't compile Cinerella 4.4. Last messages I get from the compiler are below.

1) How can fix the compilation? Seems like some GCC or lib incompatibility. I use Ubuntu 12.10.

2) Can I get Cinerella binaries somewhere?

gcc -c -fno-implicit-templates -O3 -Wall -DSUPPORT_EDITLINE -I../include -DINSTANTIATE_TEMPLATES siod.cc
In file included from ../include/EST_THash.h:46:0,
        from siod.cc:31:
../include/EST_TIterator.h: In instantiation of ‘EST_TStructIterator<Container, IPointer, Entry>::EST_TStructIterator(const Container&) [with Container = EST_THash<EST_String, EST_Regex*>; IPointer = EST_THash<EST_String, EST_Regex*>::IPointer_s; Entry = EST_Hash_Pair<EST_String, EST_Regex*>]’:
siod.cc:47:3:   required from here
../include/EST_TIterator.h:212:7: error: ‘begin’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
../include/EST_TIterator.h:212:7: note: declarations in dependent base ‘EST_TIterator<EST_THash<EST_String, EST_Regex*>, EST_THash<EST_String, EST_Regex*>::IPointer_s, EST_Hash_Pair<EST_String, EST_Regex*> >’ are not found by unqualified lookup
../include/EST_TIterator.h:212:7: note: use ‘this->begin’ instead
../include/EST_TIterator.h: In instantiation of ‘EST_TRwStructIterator<Container, IPointer, Entry>::EST_TRwStructIterator(Container&) [with Container = EST_THash<EST_String, EST_Regex*>; IPointer = EST_THash<EST_String, EST_Regex*>::IPointer_s; Entry = EST_Hash_Pair<EST_String, EST_Regex*>]’:
siod.cc:47:3:   required from here
../include/EST_TIterator.h:292:7: error: ‘begin’ was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
../include/EST_TIterator.h:292:7: note: declarations in dependent base ‘EST_TRwIterator<EST_THash<EST_String, EST_Regex*>, EST_THash<EST_String, EST_Regex*>::IPointer_s, EST_Hash_Pair<EST_String, EST_Regex*> >’ are not found by unqualified lookup
../include/EST_TIterator.h:292:7: note: use ‘this->begin’ instead
make[3]: *** [siod.o] Error 1
make[2]: *** [siod] Error 2
make[2]: Leaving directory `/home/ondra/sw/vid/cinelerra-4.4/thirdparty/speech_tools'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/ondra/sw/vid/cinelerra-4.4'
make: *** [all] Error 2
share|improve this question
    
I've found the binaries link: cinelerra.org/getting_cinelerra.php#ubuntu –  Ondra Žižka Mar 18 '13 at 5:04

1 Answer 1

I found a solution to this problem here: http://www.calcmaster.net/cinelerra/forgotten-guide/01-installation/build-compile-cinelerra/

share|improve this answer
    
Welcome to Superuser, please provide all information relative to your answer in your answer as to avoid link rot. –  50-3 Sep 17 '13 at 6:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.