Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've downloaded a fedora-based embedded linux (Endian Firewall Community release 2.5.1). The version of kernel is 2.6.32.43-57.e43.i586. It only has smart package management (and rpm). I can't install yum package manager, and also there is no gcc/gmake to install yum from source. I want to install PHP through yum and I can't install php through rpm. There is error and also so many errors. Do you know where is the channel smart checks to install dependencies? I got fedora 18 and the RPM packages don't install and show cpio error of public key.. How can I install yum?

share|improve this question

It seems like Endian Firewall does not come with Yum, thus there are no specific repos.

http://iandunn.name/installing-additional-software-on-endian-firewall/

share|improve this answer
    
when I type smart install vault.centos.org/4.0/os/i386/CentOS/RPMS/…;, I get the error below: public key not available the same error with smart install mirror.centos.org/centos/5/os/i386/CentOS/… Thanks! – Mustafa Asghari Mar 18 '13 at 13:02
    
that error has gone by set conf FALSE description I didn't see before. Anyways; the new error: Can't install yum-2.2.0-1.centos4.2@noarch: no package provides yumconf – Mustafa Asghari Mar 18 '13 at 13:10
    
Can you include the main points of the article here. If the link ever dies your answer won't be much use. – ChrisF Mar 18 '13 at 13:20
    
I added channel to smart and php is being installed. hope it will work. – Mustafa Asghari Mar 18 '13 at 13:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .