Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows 8 machine installed three updates last night, and then rebooted. When I logged back in this morning to continue working, I noticed that I could no longer access any web application I had in IIS (404 for every application URL). I looked further, and realized I got a 404 when trying to access http://localhost/

Tried an iisreset from an Administrator Command prompt, but got an error that:

'iisreset' is not recognized as an internal or external command

...so IIS is no longer installed?

I went to the Control Panel > Add/Remove Windows Features and noticed that Internet Information Services was now unchecked!

I've already started the process of re-adding IIS through Add/Remove Windows Features, but I'm still curious about the cause (and prevention of future occurrences). Has anyone else seen this issue?

The updates installed were:

  • Update for Microsoft Lync 2013 (KB2760556) 64-Bit Edition
  • Definition Update for Windows Defender - KB2267602 (Definition 1.145.2025.0)
  • Security Update for Windows 8 for x64-based Systems (KB2807986)
share|improve this question

closed as too localized by Breakthrough, Nifle, Scott, HackToHell, Tog Mar 19 '13 at 7:52

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

some form of web server is installed otherwise you would not get a 404 error, you would get the same error if you went to a non existing website. A 404 error means the server is running but it can't find the page you are looking for. Check and find out who is serving up that 404 error page and hijacked port 80 on your machine. –  Scott Chamberlain Mar 18 '13 at 15:06
That was my thought too, but I have no other installed apps which have a webserver component. It seems as though IIS was partially removed (no IIS Manager pinned in start menu where I had it, no app results in Windows Search for "IIS", and iisreset.exe no longer existed in the %PATH% like it normally does), but still there in some form as it provided the 404 Error? Unfortunately I can't check anymore, as I already re-installed IIS now (I had to get back to a working state ASAP). –  TheSoftwareDev Mar 18 '13 at 17:22
I would start the command prompt up as administrator and do netstat -abp TCP and find out who currently is serving that 404 error and start there. (edit, wrote this before you added the comment about re-installing IIS, I would just answer your own question saying reinstalling IIS resolved it (and mark it accepted in two days) or delete the question) –  Scott Chamberlain Mar 18 '13 at 17:26
Voting to close this question as not constructive, since the issue was resolved, but the problem can't be recreated. None of the aforementioned Windows updates affected any files related to IIS (I checked the Microsoft KB articles manually), so it's unlikely that the updates themselves were the cause (although I won't 100% rule them out as it's possible for updates to do more than just update files). –  Breakthrough Mar 18 '13 at 19:00

1 Answer 1

up vote 3 down vote accepted

I ended up fixing the problem by re-installing all IIS features I needed again (under Settings: Turn Windows Features On or Off).

No explanation as to why/how this might have happened, though.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.