Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

have an Asus Sabertooth X79.

I often get corrupted files. I checked the RAM, but memtest finds no errors. To avoid the possibility of disk errors, I tried copying files to tmpfs.

If I copy from the network, I get md5sum mismatches about once in 10 times using a 6Gb file. Copying from RAM to RAM, I didn't get mismatches.

I get a very high number of errors in ifconfig (compared to others PCs I just took as reference, which have 0 with much more traffic). Here is an example

RX packets:13972848 errors:200 dropped:0 overruns:0 frame:101

The motherboard is new, but do you think there're some problems with it? What could I use to test the (integrated) network adapter? What else do you think I should double check?

--edit-- I tried another NIC on the same PC, it works with speeds of 1Gbit from the same LAN cable (clearly coming from the same switch)

share|improve this question
1  
Crosspost: serverfault.com/questions/488901/… –  mpy Mar 18 '13 at 17:01
    
closed as offtopic at serverfault –  Fabio Dalla Libera Mar 19 '13 at 15:51

2 Answers 2

up vote 0 down vote accepted

Typically I don't see errors from ifconfig unless it's a wireless interface. I agree with your suspicion that it is failing hardware, although you might want to try another network cable that you know works to eliminate that. Errors on RX only could also indicate that there is an issue with the transmitting hardware.

There's some "self test" utilities for NICs that I've seen come with Windows NIC drivers.

You should be experiencing slowdown and not file corruption, though, as both TCP and UDP have checksums to throw out bad packets. So bad packets should not be making it into your files, unless the programs you are using to receive data are doing something weird. If you have checksum offloading enabled you may want to try to disable it.

Also might try looking into newer firmware for your NIC if your NIC is one of those types.

That link talks about ethtool. You can also use ethtool IIRC to set the NIC into 100Mbit or 10Mbit mode to slow it down and see if that helps.

Make sure you eliminate the transmitting hardware as an issued.

share|improve this answer
    
setting to a slower speed stops the errors. The funny thing is that if I remove the LAN cable (so obviously coming from the same switch) and plug it to another NIC on the same PC set at 1Gbit, that one gives no errors –  Fabio Dalla Libera Mar 19 '13 at 15:56
    
btw, the corruption was indeed due to failing RAM, which oddly, passes memTest –  Fabio Dalla Libera Mar 19 '13 at 16:03

You can use software like Wireshark to analyse all incoming and outgoing packets. Then you can see if there are any CRC checksum fails. If not, then you're sure the data is received correctly by your ethernet card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.