Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using Notepad++ in Windows for some time, and while I think it's a good editor, I decided to go back to Emacs to try to learn to make the most of it (writing some elisp and such).

As I do like Notepad++ I don't want to uninstall it, but I'm failing to get notepad++ to stop taking back file associations for certain file types like .txt and .xml.

If I right-click on the file, choose "open with > Choose default program..." and set it to the emacs windows client, I can see the icon flicker shortly, as if it changes, but then immediately changes back again.

I've disabled all file associations from the Notepad++ settings, so the "Registered Exts:" list is completely empty.

Does anyone know if there is something else I can do to stop it taking back the file associations?

(just thinking: is it possible that I need to reboot after disabling the associations?)

EDIT:

Thank you all for your help.
Unfortunately, I haven't had much time to use at figuring out what's causing this. So I installed Notepad++. Strangely enough, this wasn't what was doing it, and when I now try to associate it with Emacs, it does the same flickering thing, and next time I do a normal "Open" it asks me what to open the file with (so, while it's not bound to Notepad++ any more, it still doesn't allow me to rebind it to Emacs. As a test I've done the same with the normal MS Notepad, and it also doesn't allow me to rebind to that... so, it seems it's neither a Notepad++ or Emacs issue, but something else (Windows itself?) stopping me rebinding the files.

I just tried going through Control Panel > Default Programs > Set Associations and it currently says:

Name            Description                           Current Default
.txt            TXT File                              Unknown application

I've tried changing it from here (through Change program...) and that doesn't change anything. It still says "Unknown application" and it still opens with the "Open with" window.

As a side note, should I rename my question, now that it seems to be unrelated to Notepad++?

EDIT 2:

I just tried changing the association of file that was never associated with Notepad++ (.css associated with Notepad2), and that has the same (lack of) effect. Just to cement that this is definitely not a Notepad++ related issue.

share|improve this question
    
Does this happen while Notepad++ is running? –  Oliver Salzburg Mar 18 '13 at 15:11
    
It happens whether Notepad++ is running or not. I can't find any "notepad++ agent" type processes in the task manager that might be doing something like this... –  Svend Hansen Mar 18 '13 at 15:16
2  
That's what's confusing me. There should be something that is doing the change. You could try to run Process Monitor and change the association once more, then you should be able to see the access to the corresponding registry key in Process Monitor. If another application changes it back, it should be in the log as well. That could be helpful in finding the source. –  Oliver Salzburg Mar 18 '13 at 15:21
    
+1: This does definitely seem to be a good idea, the only problem is that I find it hard to read the Process Monitor, with all the things I've got running. Might have to wait until the end of the day and try to shut everything off to make the log more quiet ;) –  Svend Hansen Mar 18 '13 at 15:38
    
Yeah, there will be a lot going on in the log. You're going to want to search for part of the registry key that is being changed (possibly HKEY_CLASSES_ROOT\.txt). Once you find the right log entry, you can easily create a filter (right-click, Include...) for other accesses to that key. –  Oliver Salzburg Mar 18 '13 at 15:44

2 Answers 2

Open Notepad++ as "Administrator" or "root" then remove the extensions associated with it. After removing Windows will ask how to open this file choose another application.

share|improve this answer

Go to Settings -> Preferences and remove any Registered exts:

enter image description here

share|improve this answer
    
He stated in the question that he's already done this. –  ϺОŞΣŞ Mar 18 '13 at 15:26
    
I've already done this... though I haven't rebooted since (have a lot of things running) –  Svend Hansen Mar 18 '13 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.