Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Up until today, I had Chrome setup to handle magnet links just fine. I'd click on the magnet link, a little popup would ask me if I want to launch the magnet application or do nothing, then the application would load with the passed argument. The handler is Deluge.

However, today I made the stupid mistake of installing Shareaza on my system. Without asking me, it overrode my magnet settings by making itself the handler. Everytime I reset the handler in Chrome or directly in the system registry, it would immediately revert back to Shareaza whenever I tried to open a magnet link. Since it had no processes running, I have to assume there was another registry setting causing it.

Anyway, I got fed-up and uninstalled Shareaza completely. I then restored the magnet handler to Deluge. But now I can't get it work work!

It DOES bring up the popup with the "launch application" and "do nothing" buttons. But when I click on the launch one, nothing happens. It's identical to the behavior of clicking "do nothing." I tried uninstalling/reinstalling Deluge, upgrading to its latest version, restarting Chrome, etc. Nothing has worked.

I just spent the last two hours on Google trying to find a fix for this. Instead, all the issues seem to center around nothing happening at all when magnet links are clicked. In my case, I still get the confirmation popup (and yes it does show the correct information; i.e. it's going to Deluge), but then clicking "launch" just makes the popup go away and nothing else happens.

I've tried doing this with Deluge already running and not running. No effect. I ran Process Monitor when Deluge wasn't already running and evidently the process is never even being started at all. This is also confirmed by monitoring the process list in the task manager. This leads me to believe that it's some sort of issue with Chrome; perhaps an overriding registry value that Shareaza snuck in and didn't bother to remove.

Can anybody help me with this?! This is driving me nuts!

Thanks!

share|improve this question

migrated from stackoverflow.com Mar 18 '13 at 15:14

This question came from our site for professional and enthusiast programmers.

    
Oh and yes, I have checked to make sure that Chrome's "Local State" file does not contain the magnet true/false entry, so that's not it. –  Kris Craig Mar 18 '13 at 12:35
    
Under Set Associations in the Control Panel, if you scroll all the way down to the Protocols section, what program is shown as being associated with Magnet URIs? Try changing it from there to Deluge if it isn't already so. –  Karan Mar 19 '13 at 21:07

1 Answer 1

Try using regedit.exe and then search for "shareaza" It should find two folders each having a couple of sub folders and several keys. Delete both of them.

It should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.