Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a reason this port is open, a quick Nmap scan and Nessus scan reveal it's open, why?

Are there any ramifications if I close this port via the firewall rule set?

Or does anyone here now more info about this port besides Google?

WTF? 1)http://www.symantec.com/connect/blogs/who-left-tunnel-door-open-windows-firewall-vista-0 I know the talk is about Vista, but I am pretty sure it's the same port on 7, also.

2)Port 5357 common errors:The port is vulnerable to info leak problems allowing it to be accessed remotely by malicious authors. (Web Services for Devices)

I am blocking this crap, if I have issues will just re-enable. Damn windows.

Inbound rule for Network Discovery to allow WSDAPI Events via Function Discovery. [TCP 5357] You just got blocked, until I break something, will see.

Time to re-Nmap and re-Nessus. Nmap scan 0 open ports after closing Port 5357,Win7 still works for now, one more scan with Nessus just to make sure all is well.

share|improve this question

1 Answer 1

up vote 9 down vote accepted

This port is opened probably because you have Network Discovery enabled in a Public Network profile.

To make sure if this is the case, don't block it and disable Network Discovery for any public profile you may have.

  • Go to Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
  • Disable Network Discovery on your Home Network and Public Network
  • (Not sure if you need a reboot)
  • Check your ports again. Should not be opened.
  • Enable it in your Home Network and leave it off in your Public Network.

If you are using Windows Firewall it will be correctly mapped and it won't accept connections from outside. Only from within your home network. If you are using a personal firewall, make sure it has port level access so that you can set it up to only accept incoming/outgoing connections from/to your home network.

share|improve this answer
    
Thanks, did not think about using the Control Panel, I was just thinking ports open...firewall...block open ports. That's some good info to know, I will use this method on my laptop also. –  Registered Oct 18 '09 at 3:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.