Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am SSH'ing to a server (running CentOS release 5.4 (Final)). I opened vim, and when I hit shift+v to try to get into "Visual Line" mode, all I get is a beep noise.

Why? Why can't I access visual mode in Vim? echo $TERM says xterm.

I SSH'd into another computer (running Debian), and pressing shift+v worked exactly as I'd expect (this machine also has echo $TERM equal to xterm).

What setting do I need to check to make Vim act the way I want? Or how can I get into visual mode without being beeped at?

share|improve this question
    
Are you sure that vim is actually installed and not nvi or something else with a symlink? – Zoredache Mar 18 '13 at 19:24
    
@Zoredache: When I open vim, it says: VIM - Vi IMproved version 7.0.237 – Rocket Hazmat Mar 18 '13 at 19:37
up vote 3 down vote accepted

Does "vim --version" show "Tiny Version" immediately before the feature list? If so, that particular Vim binary probably does not have support for visual mode. Check the actual feature list for +visual/-visual. If it is a minus, that confirms that the support is not there.

As this is CentOS 5, I would recommend trying this to get a fully enabled Vim (as root):

yum install vim-enhanced
share|improve this answer
    
Tiny version without GUI. Features included (+) or not (-): -visual. I didn't know there was vim-minimal vs vim-enhanced. On most other linux distros, it's just vim. – Rocket Hazmat Mar 18 '13 at 19:38
    
Yep. That is exactly why it wasn't working! Thanks so much :-D – Rocket Hazmat Mar 18 '13 at 19:38
    
@RocketHazmat, no. On most other distros, the default Vim is vim-minimal or vim-tiny and you must manually install a proper vim. – romainl Mar 18 '13 at 20:04
    
@romainl: I use Arch Linux and Gentoo :-) – Rocket Hazmat Mar 18 '13 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .