Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to bind the # key to a tmux command. I have tried

bind \# command-prompt -p "create vert pane from (put window-number[.pane-number]): " "join-pane -sv ':%%'"
bind # command-prompt -p "create vert pane from (put window-number[.pane-number]): " "join-pane -sv ':%%'"

It interprets the # character as a comment in the tmux.conf file.

share|improve this question

migrated from stackoverflow.com Mar 18 '13 at 21:33

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

For #, you need to use quotes; the backslash escaping only really works for the semicolon.

Also, your join-pane command probably need -vs instead of -sv; otherwise the -s option will take v as its argument leaving the prompted value as an unsupported argument to the command itself.

bind '#' command-prompt -p "create vert pane from (put window-number[.pane-number]): " "join-pane -vs ':%%'"

Either double or single quotes should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.