Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have all my ftp accounts mounted via CurlFTPfs with allow-others option. All directories have --- --- rwx (0007) permission after ftp mount with umask=0770 . This way I can log as another user (than root) in shell with full access. However it is not possible to modify files via SAMBA. How to mount SAMBA share to have all permissions? Here is my smb.conf

[global]
dos charset=UTF8
unix charset=UTF8
workgroup = PPHU
server string = Samba Fileshare running %v
security = user

unix password sync = no
log level = 1
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
wins support = no
name resolve order  = host lmhost wins bcast

[ftp]
comment = FTP
path = /mnt/ftp
create mask = 777
directory mask = 777
share|improve this question

1 Answer 1

You need to add this directive to your mount command:

-o allow_other,uid=1000
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.