Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run Mate 1.4.2

When I click 'Home Folder' from 'Places' menu on top it launches easytag application instead of caja. I.e. completely unrelated application.
I have no idea how it happened and have no clue where to look to fix it.

When I browse folders within caja it works fine.

Please, suggest where to look first.

share|improve this question
    
Deleted my answer, since it did not address your problem. What happens when you double click a folder icon in the desktop? It opens correctly with caja? Is caja set as the default file manager? What happens if you just run caja from a terminal? – terdon Mar 21 '13 at 14:04
    
It opens fine when I double click on a desktop folder. caja also runs from terminal as expected. How do I check that caja is default manager? I think that is the area we're looking for. – Max Tsepkov Mar 21 '13 at 18:07

Oh, I found the problem.

Go to System -> Preferred Applications. On System tab the File Manager was set to EasyTag.

Have no idea how this come, but when I changed it back to "Open Folder" it obviously worked.

I guess it is a problem with Easytag debian package. It adds itself as a file manager for some reason. And because Easytag is alphabetically upper than "Open Folder" (caja) it was selected by default.

I am on Debian Wheezy.
If someone can confirm this behaviour after installing EasyTag I could file a bug for it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .