Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For testing purposes I installed virtualbox to simulate a linux(64 bit ubuntu) server.

I configured my network settings like this: Adapter 1: NAT Adapter 2: Host-only

with my etc/network/interfaces configured like this:

#loopback network interface
auto lo
iface lo inet loopback

# primary network interface
auto eth0
iface eth0 inet dhcp

#the host-only network interface
auto eth1 
iface eth1 inet static
address 192.168.56.101
netmask 255.255.255.0
network 192.168.56.0
broadcast 192.168.56.255

While my host is operating on 192.168.1.23 with standardgateway 192.168.1.1.

I am able to ping from my host to this virtualbox (192.168.1.23>192.168.56.101) and vice versa, reach the website, database running on the virtualbox etc.

But now I installed an FTP with

sudo apt-get install vsftpd

following this guide: http://www.cyberciti.biz/faq/ubuntu-vsftpd-ftp-service-server/

Also configured this ftp-server (according to above link)

But whenever I try to reach this virtualbox using FTP I AM able to connect, and I get the folderlist (at least I see '257 /home/user' in filezilla) but after 10 seconds I get the error:

- Lost connection
- Unable to retrieve folderlist

How to resolve this issue?

(I do not want to use the network-bridge-adapter..)

share|improve this question

migrated from stackoverflow.com Mar 19 '13 at 7:46

This question came from our site for professional and enthusiast programmers.

    
I don't see any reason why your setup should not work... maybe some kind of firewall involved or something related to FTPs active/passive mode? –  cmur2 Mar 18 '13 at 17:52
    
You are right, it was the firewall of the linux(guest). Thanks! –  Lazykiddy Mar 19 '13 at 11:13
add comment

1 Answer 1

The firewall 'libwww-perl' on the linux (guest) virtualbox was blocking the connection somehow!

To disable the firewall I used

sudo nano /etc/csf/csf.conf

and changed

TESTING='0'

to

TESTING='1'

I'm sure you can make an exception on this firewall but I dont really need it since I only use this virtualserver local.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.