Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to update my glibc from 1.2.10 to 2.12. Are there any problems regarding dependency for other tools and software currently installed using previous version of glibc on CentOS release 6.3 (Final) with kernel 2.6.32-279.9.1.el6.x86_64?

share|improve this question
    
I think you may not be looking at libc. Your CentOS system does not run glibc 1.2, at least not as the base libc. CentOS 2.1 already had been on glibc 2.2.4. Are you sure it's glibc? –  Rich Homolka Mar 19 '13 at 17:28
    
yes I am damm sure I use glib-config --version 1.2.10 –  krishna Mar 19 '13 at 17:58
1  
I see, please update your question. glib-config relates to GLib, which is part of gnome. Your question asked glibc (and the answer below is regarding to glibc). I know it's confusing, but they are two very very different library packages. –  Rich Homolka Mar 19 '13 at 18:24

1 Answer 1

up vote 0 down vote accepted

Absolutely. The rest of the system must be upgraded along with it. Otherwise a whole lot of binaries will cease to run because they are linked against a different version of Glibc.

In cases where the upgrade is minor, this tends not to be an issue.


If you name your distro an version, people might give you more specific answers.

share|improve this answer
    
I am running on CentOS release 6.3 (Final) with kernel 2.6.32-279.9.1.el6.x86_64 –  krishna Mar 19 '13 at 17:13
    
BTW: user is asking about GLib, not glibc. I'd have called this out in my above comment, but I have no idea how to type Cyrillic on my keyboard :) –  Rich Homolka Mar 19 '13 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.