Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am dealing with a strange problem with wifi on my raspberry pi (I`m not sure if this has influence). I tried this with 3 different usb wifi devices. All of them are working perfectly if I connect to AP with wpa_supplicant. Troubles start when I start kismet (2011-03-R2) - I receive these error messages:

mac80211_setchannel() could not set channel 1/2412 on interface 'te0mon' err -25

The original name wifi interface name is te0, it`s configured in udev, I just needed to distinguish all my wifi devices. The same problem is with iw command:

iw te0 set channel 1

returns:

command failed: Device or resource busy (-16)

The device is down, not used by any other process (as far as I can recognize). These troubles started after upgrading to kernel 3.6.11 from 3.2.something (I don't remember this exactly). I can't downgrade it because other problems were solved by this. I even tried to download iw version 3.8 (the newest) and compatibility drivers 3.9 and it`s still the same.

Do you have any idea, what could be wrong? How to debug this (find, why the device is busy)?

Thanks for any help.

share|improve this question
    
Try iw te0 set freq 2412 ? –  BatchyX Mar 19 '13 at 13:29
    
Thanks, but it`s still the same. –  Pavel Mar 19 '13 at 13:34
    
What is the current state of your vifs ? (iw dev). If there is both a managed and a monitor vif, remove the managed one and retry. mac80211 assumes that monitor interfaces are slaves to other vifs if there is one. –  BatchyX Mar 19 '13 at 13:38
    
If I delete the te0 interface, kismet server doesn't work at all, because there is no te0. Ill try to configure kismet to use te0mon, but even if this helps, it wont answer why iw te0 set channel 1 doesn`t work. –  Pavel Mar 19 '13 at 13:47
    
setting the channel of a unconnected managed mode vif makes no sense when you think of it. a managed mode vif should either scan or use the channel specified via the AP's beacons. If you want to monitor things, use only a monitor vif and set its channel/freq accordingly. –  BatchyX Mar 19 '13 at 13:54

1 Answer 1

Thanks to BatchyX I have a solution:

  • create minotor device iw dev te0 interface add te0mon type monitor
  • delete managed te0 iw dev te0 del
  • configure kismet to use te0mon ncsource=te0mon:type=mac80211,name=te0mon
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.