Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded from Firefox 3.6 to Firefox 19 (!!! how do they manage to release sixteen major versions in just three years?), and now find that the arrow keys scroll the page by much more than they used to. Previously a single downarrow press would scroll down by about 1 line of text; now it scrolls 2 or 3 lines. That is rather annoying.

I suppose there must be some setting in about:config I can adjust to get the single-line scrolling back, but where? Searching for "scroll" in the list doesn't turn up anything promising (which works).

(I've seen various places on the web recommend the "Yet another smooth scrolling" extension, but it doesn't do quite the right thing -- it lets me control the amount of scroll alright, but even if I turn its smoothness controls all the way down to 0, it stills seems to scroll each line in two quick steps rather than immediately).

share|improve this question
    
The can release 16 major version quite easily with their following. –  Griffin Mar 19 '13 at 14:05
add comment

1 Answer

up vote 3 down vote accepted

This should work without any extensions.

First, you'll want to adjust the toolkit.scrollbox.verticalScrollDistance flag in about:config. This should be the scrolled distance. My current default value seems to be 3 (which would match your suspicion).

If you want to disable the smooth scrolling effect, you can adjust general.smoothScroll.lines.durationMaxMS and general.smoothScroll.lines.durationMinMS to 0.

share|improve this answer
    
That works, thanks! Don't know how I could have overlooked that setting. –  Henning Makholm Mar 19 '13 at 15:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.