Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I add all other users to this:

image1.png

In the "Enter the object names to select (examples)" field.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I believe 'Everyone' would suffice. At least in our domain it does.

share|improve this answer
    
Everyone blocks me as well. I can still modify the security after that, and I have everything checked under "allow" in my personal username –  Chipperyman Mar 19 '13 at 14:15
    
Is this in a personal work group or a domain enviornment? If it's a personal work group, I believe you'd have to add everyone's username. If a domain, you could always create a group and add the members you want to deny access to followed by adding said group in the deny list. –  Trey Mar 19 '13 at 14:17
    
I want to deny access to everyone but me, and there's thousands of users on the network. I can't manually add everyone. It'd take too long and by the time I finished there would be a change somewhere. –  Chipperyman Mar 19 '13 at 14:18
1  
If you were to add only your account under full control and remove all other accounts from the security window, it should accomplish what you desire. –  Trey Mar 19 '13 at 14:21
    
One more thing, if this folder is also a shared folder, be sure to mirror the security rights on the share permissions. –  Trey Mar 19 '13 at 14:27

Windows has a built-in hidden group 'Everyone', but it is distinct from 'all other users' in the sense that it includes you. Since denied permissions take precedence over allowed permissions, you cannot use this group to prevent anyone but you from accessing the object.

Instead, you should untick the 'allow' checkboxes for all relevant user groups and add yourself as an exception, e.g.:

Security settings

share|improve this answer
    
I already did that, but it didn't work. –  Chipperyman Mar 19 '13 at 16:32
    
@chipperyman573: Didn't work how? These security settings do exactly what they're supposed to do, but that may not be what you want. Could you elaborate? –  Marcks Thomas Mar 19 '13 at 17:11
    
It acted as if the group with just me didn't exist. The "everyone" group were the permissions I got. –  Chipperyman Mar 22 '13 at 0:12
    
@chipperyman573: That's by design; both sets of permissions apply to you, but denied permissions take precedence over allowed ones. Remove 'everyone' from the list. Not explicitly giving users access rights is sufficient to keep them out. –  Marcks Thomas Mar 22 '13 at 1:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.