Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have nearly 2TB of Movies and TV Shows copied to iTunes on an external hard drive. Last night, I was unplugging a cord behind my desk and I accidentally unplugged my HD. Well, when I plugged it back in and tried to open iTunes, it said that it was corrupted.

I couldn't figure out a work around for this so I made a new iTunes Library and pointed it to my media. I still couldn't get it to recognize my movies etc. This morning I tried to manually open one of the movies with Quicktime player and it says that it is not a movie file. HELP!!! This was days and days of work to transfer my DVD collection over.

I know this should've been backed up. I just finished transferring them and purchased another drive for this purpose. This happened before I was able to back them up.

share|improve this question
    
Is this on Windows or Mac OS X? –  James Mar 19 '13 at 15:28
    
@James Mac OS X –  daveMac Mar 19 '13 at 15:29

1 Answer 1

Let's run a chkdsk on the external drive that will hopefully fix your problem.

  1. Open My computer, right click your external drive, and click properties
  2. Click Tools, then Check Now
  3. Check the box to 'automatically fix system errors' and the box 'scan and restore bad sectors'
  4. Click Start

Information should appear in the chkdsk window as it performs the check. Hopefully this helps you out!

EDIT: I'm assuming it's a windows box...

share|improve this answer
    
I should've pointed out that I am using a mac. –  daveMac Mar 19 '13 at 15:28
1  
There's a baked-in disk repair tool in Mac called Disk Utility. It's not very robust, but I'd give it's repair function a try. You can find it if you search for 'Disk Utility' on your home screen –  Trey Mar 19 '13 at 15:42
    
I used Disk Utility already without success. –  daveMac Mar 19 '13 at 15:43
    
You might want to give a third party tool a look. Disk Warrior is great, however it's pricey: alsoft.com/diskwarrior –  Trey Mar 19 '13 at 15:45
    
I used Disk Warrior too. It appears that the files are corrupted. –  daveMac Mar 19 '13 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.