Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On the following configuration -Asus Sabertooth X79 -Intel Core i7 3930K -8 of these 8Gb RAM http://linux.about.com/od/commands/l/blcmdl8_ethtool.htm

One of these RAM is failing. When I plug it in and copy files from the network to a ramdisk (tmpfs) they get corrupted. I often get blue screens on win and kernel panics in linux. However, it passes memtest. If I copy from the ramdisk to the ramdisk, I do not data corruption either. The MB slot seems not to be the cause, since the problem does not depend on whether I plug it in. What could be the reason for the RAM to pass the test but be actually not working. What could be a way to better check that RAM?

--edit-- I tried putting another network controller, but the problem persists. I updated the BIOS to the last version, and use the default settings, the CPU is @3.2GHz When I use 6 out of 8 RAMs, if I replace the "suspected faulty" one with another one, it works

share|improve this question
    
Is it possible your disk drive itself is corrupted? What about the network controller? –  Breakthrough Mar 19 '13 at 16:17
    
I tried putting another network controller, and I write to tmpfs (in ram) the data. Furthermore, when I use 6/8 RAMs, if I replace the faulty one with another one, it works. –  Fabio Dalla Libera Mar 19 '13 at 16:21
    
Are you sure it passes memtest? The full memtest, not just a once-through check? –  vonbrand Mar 19 '13 at 16:31
    
yes.Now I tried to put just that single RAM, and wait several passes, in case it's a temperature problem. –  Fabio Dalla Libera Mar 19 '13 at 16:56
    
@FabioDallaLibera: When you test a stick by itself, you're not testing the same thing at all. The timing and loading is different if the stick is alone. –  David Schwartz Mar 19 '13 at 17:01

1 Answer 1

There are number of other things it could be - faulty processor/motherboard springs to mind, however, I would have thought this could be flagged up by memtest....

... You say you have a 3930k, Are you overclocking it? I have seen many people complain of the same issues as you when clocking too high. I would recommend not to overclock at all and see if you have the same issues.

Next, I would see if you have any BIOS updates you can do.

If this doesn't fix it, try swapping the memory around and running again.

Lastly, if you were able to copy from ramdisk to ramdisk without issue, but the issue shows up from network to ramdisk, can you isolate the network card and make sure that isn't faulty?

share|improve this answer
    
thank you, I edited my question –  Fabio Dalla Libera Mar 19 '13 at 16:24
    
Even if he's not overclocking I wouldn't be surprised if this is the issue. If the hardware permits it I would try underclocking and see if the problem goes away. I'm thinking the chip is failing under max write load, something that doesn't happen with the ramdisk copy as there are as many reads as writes. Nor would it happen with Memtest as it's checking what was written--again, half reads. –  Loren Pechtel Mar 19 '13 at 17:36
    
@LorenPechtel Thank you, this may be the reason. Do you know any tool that tests write loads? –  Fabio Dalla Libera Mar 21 '13 at 11:40
    
@FabioDallaLibera: I don't have the foggiest idea of a tool. I was just looking for what existed in the failure cases but not the test cases and large block writes to memory are the thing that stood out to me. –  Loren Pechtel Mar 22 '13 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.