Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install one package but it depends on some other packages. While installing it aborts and tells me the following:

Depends: python (>= 2.6.6-7~) but 2.6.6-3+squeeze7 is to be installed
Depends: python-sqlalchemy (>= 0.7~) but 0.6.3-3+squeeze1 is to be installed

I don't know how to solve this dependancy problems. I looked at google and installed

python-all-dev

from: http://packages.debian.org/squeeze/python-all-dev

But it didn't solve the problem. Can anyone shed some more light on this issue. Thanks

share|improve this question

migrated from stackoverflow.com Mar 19 '13 at 16:21

This question came from our site for professional and enthusiast programmers.

    
Please post the full messages you received so we can see what happened. Thanks –  average Mar 19 '13 at 11:04
    
actually the package i want to install does not support debian squeeze, so i need to upgrade it to wheezy. i am doing it now –  Yasin Mar 19 '13 at 11:14
    
You could have just used pip and installed all the needed dependencies. Upgrading your whole system for one program seems to be overkill to me –  average Mar 19 '13 at 11:26
    
actually it's a vm and i will run only this program. so it's worth –  Yasin Mar 19 '13 at 13:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.