Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using handbrake to convert my DVD's to .MP4 and have set the default output path

Tools -> Options -> Output Files

In here there is Default Path: which I have pointing to my Movies folder and then there is Format: which is how the file is named. My issue is that my directory structure is

\Movies
    \Title
        Movie.mp4

I'm trying to figure out how to have handbrake create the new Title directory and place the file in there.

The only options for Default path are {source_path} or {source_folder_name}, which doesn't accomplish the task as my Movies folder is not in the source directory.

Under Format the options are {source}, {title}, {chapters}, {date} I tried entering {source}\{title} thinking this would create the folder path and then insert the file, however instead the output is D:\Movies\Movie Name\Movie Name\Movie Name\1.mp4, {source}\{source} produces similar results but with the mp4 file being named correctly. I am not sure why it repeats itself so many times.

How can I automates this with handbrake?

UPDATE

I am using version 0.9.8 of handbrake on Windows 7

share|improve this question
    
I have exactly the same problem as you - I ended up getting the Handbrake UI to crash because it kept adding multiple copies of the "source" tag until the filename was too long for Windows' directory structure rules. –  evilspoons May 6 '13 at 21:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.